Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-19-2016, 11:07 PM   #1
jeremyco
Junior Member
 
Join Date: Jan 2016
Posts: 6
Unhappy DisplayLink on Linux Mint 17.3

Did anyone manage to install DisplayLink USB 3.0 on Linux Mint 17.3? It would be great if some instructions or installer file could be posted here. I've tried to follow different posts how to modify installer file, but nothing did work. Everything seems to work fine, but at the end my monitor connected to the laptop is not recognized.

Thanks
jeremyco is offline   Reply With Quote
Old 01-25-2016, 01:30 PM   #2
AdriaanNel
Junior Member
 
Join Date: Jan 2014
Posts: 3
Default

Anybody perhaps have an update on this?
AdriaanNel is offline   Reply With Quote
Old 02-03-2016, 02:15 PM   #3
PlusMinus
Junior Member
 
Join Date: Feb 2016
Posts: 3
Default

The way I see it, the problem with the current installer is that no init daemon is defined in the installation script.

The way I did it (IIRC) was to install the file you downloaded like you normally would

Code:
./displaylink-driver-1.0.335.run
then I unpacked this file

Code:
./displaylink-driver-1.0.335.run --keep --noexec
and opened the displaylink-installer.sh and changed line 9 to match the daemon I wanted to use (upstart worked, didn't try systemd).

Code:
SYSTEMINITDAEMON=upstart
And ran the extracted script

Code:
displaylink-installer.sh install

Last edited by PlusMinus; 02-04-2016 at 10:41 AM.
PlusMinus is offline   Reply With Quote
Old 02-04-2016, 06:35 AM   #4
jeremyco
Junior Member
 
Join Date: Jan 2016
Posts: 6
Smile

I've solved the issue and managed to make it work on LinuxMint 17.3.

The procedure is as PlusMinus explained with only difference that install parameter should not have -- in front of it.
I was aware of this approach earlier and tried it many times, but the problem in my case was that unpacking the file did not unpack properly. Directory x64 was empty, and once I manage to extract it properly, everything went smoothly.
jeremyco is offline   Reply With Quote
Old 05-16-2016, 02:57 PM   #5
samjam
Junior Member
 
Join Date: May 2016
Posts: 22
Default

Quote:
Originally Posted by jeremyco View Post
I've solved the issue and managed to make it work on LinuxMint 17.3.

The procedure is as PlusMinus explained with only difference that install parameter should not have -- in front of it.
I was aware of this approach earlier and tried it many times, but the problem in my case was that unpacking the file did not unpack properly. Directory x64 was empty, and once I manage to extract it properly, everything went smoothly.
The directory is empty if you already installed once. You have to unpack again each time.
samjam is offline   Reply With Quote
Reply

Tags
displaylink, mint17.3

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.