Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-16-2020, 09:26 AM   #1
mabu
Junior Member
 
Join Date: Jun 2020
Posts: 3
Default Displaylink driver installation fails on Ubuntu 18.04

Hello, I am trying to have an extra monitor through the DVI port of ThinkPad USB 3 Pro docking station (which has a DisplayLink label) with a Lenovo IdeaPad L340. All other drivers (sound, USBs) are working out of the box, but not the display.

I followed the installation steps here:
https://support.displaylink.com/know...rticles/684649

But that failed in the step of running the script:
Code:
sudo ./displaylink-driver-5.1.26.run 
Verifying archive integrity...  100%   All good.
Uncompressing DisplayLink Linux Driver 5.1.26  100%  
DisplayLink Linux Software 5.1.26 install script called: install
Distribution discovered: Ubuntu 18.04.4 LTS
WARNING: Version 1.7.0 of EVDI kernel module is already running.
Please reboot before attempting to re-install DisplayLink Linux Software.
Installation terminated.
After some googling; I did the following:
Code:
$ sudo ./displaylink-driver-5.1.26.run --keep --noexec

displaylink-driver-5.1.26$ sudo ./displaylink-installer.sh uninstall
DisplayLink Linux Software 5.1.26 install script called: uninstall
Distribution discovered: Ubuntu 18.04.4 LTS
Uninstalling
Removing EVDI from kernel tree, DKMS, and removing sources.
Stopping displaylink-driver systemd service
Failed to stop displaylink-driver.service: Unit displaylink-driver.service not loaded.
Failed to disable unit: Unit file displaylink-driver.service does not exist.
Removing suspend-resume hooks
Removing udev rule
Removing Core folder

Uninstallation steps complete.
Please note that the evdi kernel module is still in the memory.
A reboot is required to fully complete the uninstallation process.
It looks like the uninstall is not going through due to displaylink-driver.service does not exist. I rebooted several times; I even tried to run Ubuntu in console mode to avoid any issue with the X server.

Following the steps here did not help:
https://support.displaylink.com/know...ent-x-upgrades

Following the steps mentioned on nvidia did not help either:
https://forums.developer.nvidia.com/...ink-evdi/73626

- lsusb command result:

Code:
$lsusb
Bus 002 Device 004: ID 17ef:1017 Lenovo 
Bus 002 Device 003: ID 17e9:433f DisplayLink 
Bus 002 Device 002: ID 17ef:1016 Lenovo 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 174f:1176 Syntek 
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 006: ID 0cf3:e500 Atheros Communications, Inc. 
Bus 001 Device 004: ID 17ef:1017 Lenovo 
Bus 001 Device 008: ID 04e8:6860 Samsung Electronics Co., Ltd Galaxy (MTP)
Bus 001 Device 002: ID 17ef:1016 Lenovo 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
- dkms status initially:

Code:
$dkms status
nvidia, 440.59, 5.3.0-59-generic, x86_64: installed
- dkms status after building DisplayLink / EVDI
Code:
$ dkms status
evdi, devel, 5.3.0-59-generic, x86_64: installed (WARNING! Diff between built and installed module!)
nvidia, 440.59, 5.3.0-59-generic, x86_64: installed
Code:
$uname -a
Linux 5.3.0-59-generic #53~18.04.1-Ubuntu
I would appreciate any kind of help; please let me know if further information is required.

Thanks.

Last edited by mabu; 06-17-2020 at 12:34 PM.
mabu is offline   Reply With Quote
Reply

Tags
displaylink, docking station, installation problem, lenovo, ubuntu 18.04

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.