Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-18-2020, 12:04 AM   #1
kngharv
Junior Member
 
Join Date: Sep 2020
Posts: 6
Unhappy external monitor not detected in Ubuntu/20.04 with DL-59xx chipset

I am running generic Ubuntu/20.04 with generic kernel.

I have two external monitors attached to my laptop. One attached to HDMI, another one attached to my displaylink hub powered by a newer DL-5910 chip (Dell*D3100) via usb/3.

The laptop has a builtin Intel GPU and a Nvidia gpu, which I use nouveau driver for it.

Installation process was smooth, and after reboot it seems that the displaylink driver has installed successfully.

However, the external monitor attached to the usb hub is simply not working.

I almost want to say it is not detected, but it's not that simple.

During the login process, gdm3 seems to know that I have two external monitors thus all monitor painted dark purple.

Once I log in, though, the external monitor attached to usb simply doesn't work.

I thought the external monitor simply wasn't detected... but when I run the following, it shows that the monitor was attached

Quote:
$ ls /sys/class/drm/*/status | xargs -I {} -i bash -c "echo -n {}: ; cat {}"
/sys/class/drm/card0-DVI-I-1/status:connected
/sys/class/drm/card1-DVI-I-2/status:disconnected
/sys/class/drm/card2-DVI-I-3/status:disconnected
/sys/class/drm/card3-DVI-I-4/status:disconnected
/sys/class/drm/card4-eDP-1/status:connected
/sys/class/drm/card4-HDMI-A-1/status:connected
and dmesg also had one line which indicated that displaylink found the attached monitor:

Quote:
[ 27.803323] evdi: [D] evdi_painter_mode_changed_notify:701 (dev=0) Notifying mode changed: 1280x1024@60; bpp 32;
(my external monitor is an old Sony which has 1280x1024 resolution. I connected it via DVI port).

I also manually edited the 20-displaylink.conf file in /etc/X11/xorg.conf.d
Quote:
Section "OutputClass"
Identifier "DisplayLink"
MatchDriver "evdi"
Driver "modesetting"
Option "AccelMethod" "none"
EndSection

Section "Device"
Identifier "DisplayLink"
Driver "modesetting"
Option "PageFlip" "false"
EndSection
I also patched the x server, gotten the deb package from this website

But still, the external monitor simply not detected by xrandr

In fact, when run xrandr --listproviders, displaylink gpu is not detected:
Quote:
Providers: number : 2
Provider 0: id: 0x46 cap: 0x9, Source Output, Sink Offload crtcs: 4 outputs: 3 associated providers: 1 name:Intel
Provider 1: id: 0xa9 cap: 0x4, Source Offload crtcs: 0 outputs: 0 associated providers: 1 name:nouveau
yet, the driver seems to loaded:
Quote:
$ lsmod|grep -i evdi
evdi 53248 4
drm_kms_helper 184320 3 evdi,i915,nouveau
syscopyarea 16384 2 drm_kms_helper,evdi
sysfillrect 16384 2 drm_kms_helper,evdi
sysimgblt 16384 2 drm_kms_helper,evdi
drm 491520 13 drm_kms_helper,evdi,i915,ttm,nouveau

Any idea/hint/pointer on how to solve this problem?

thanks in advance


Harv
ps. displaylink-debian installation script yield the same result.
Attached Files
File Type: zip DLSupportTool_Output_2020-09-17T16:30:53.029299.zip (813.6 KB, 0 views)
kngharv is offline   Reply With Quote
Old 09-22-2020, 10:07 AM   #2
kngharv
Junior Member
 
Join Date: Sep 2020
Posts: 6
Default managed to detect external monitor by swtich to wayland

Dear all:

I managed to get around the problem by switching to wayland instead of using good old X11.

Since Ubuntu/20.04 has an option of log in using wayland, it was pretty easy for me to do.

For those who ran into similar problem, may be you should give wayland a try as well.

Performance on wayland is pretty good, I actually feel it's more responsive on wayland than X11.

Good luck.


Harv
kngharv is offline   Reply With Quote
Reply

Tags
ubuntu 20.04

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.