Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-02-2020, 12:13 PM   #1
vuki656
Junior Member
 
Join Date: Sep 2020
Posts: 2
Arrow Boot to blank screen or laggy monitors? Here is what worked for me.

My experience with the display link was not present. After first installing it, I was greeted with a blank screen on boot, and after I managed to bypass that I got extremely laggy monitors.

NOTE: I'm running ryzen 7 and Nvidia GTX 1660 Ti

Here is the process that fixed laggy monitors and makes everything smooth:

1. Update kernel to latest version with mainline
a .sudo apt-add-repository -y ppa:cappelikan/ppa
b .sudo apt install mainline
c. Open mainline GUI and install the latest kernel version
2. Restart and then Install display link driver (download the ubuntu version from their website)
a. sudo apt-get install dkms
b. sudo apt-get install libdrm0dev
3. Run the driver installation file
a. Right click the file and go to properties/premissions
b. Set the access to read/write
c. Set the execute to true
d. Run sudo ./<file-name>
5. Restart
6. Install nvidia drivers
a. sudo apt-get purge nvidia*
b. sudo apt-get-repository ppa:graphics-drivers
c. sudo apt-get install nvidia-driver-450 (this one worked for me)
7. Set the graphics card as main
a. Go to and open /usr/share/X11/xorg.conf.d/10-nvidia.conf
b. Paste
HTML Code:
  Section "OutputClass" 

    Identifier "nvidia" 

    MatchDriver "nvidia-drm" 

    Driver "nvidia" 

    Option "AllowEmptyInitialConfiguration" 

    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg" 

    Option "PrimaryGPU" "yes" 

EndSection 
The important line here is PrimaryGPU. I think I had laggy monitors because ubuntu was running everything over the integrated GPU
8. Restart

Hopefully it works.
vuki656 is offline   Reply With Quote
Old 09-11-2020, 07:09 PM   #2
thopiekar
Junior Member
 
Join Date: Sep 2020
Posts: 6
Default

Quote:
Originally Posted by vuki656 View Post
My experience with the display link was not present. After first installing it, I was greeted with a blank screen on boot, and after I managed to bypass that I got extremely laggy monitors.

NOTE: I'm running ryzen 7 and Nvidia GTX 1660 Ti

Here is the process that fixed laggy monitors and makes everything smooth:

1. Update kernel to latest version with mainline
a .sudo apt-add-repository -y ppa:cappelikan/ppa
b .sudo apt install mainline
c. Open mainline GUI and install the latest kernel version
2. Restart and then Install display link driver (download the ubuntu version from their website)
a. sudo apt-get install dkms
b. sudo apt-get install libdrm0dev
3. Run the driver installation file
a. Right click the file and go to properties/premissions
b. Set the access to read/write
c. Set the execute to true
d. Run sudo ./<file-name>
5. Restart
6. Install nvidia drivers
a. sudo apt-get purge nvidia*
b. sudo apt-get-repository ppa:graphics-drivers
c. sudo apt-get install nvidia-driver-450 (this one worked for me)
7. Set the graphics card as main
a. Go to and open /usr/share/X11/xorg.conf.d/10-nvidia.conf
b. Paste
HTML Code:
  Section "OutputClass" 

    Identifier "nvidia" 

    MatchDriver "nvidia-drm" 

    Driver "nvidia" 

    Option "AllowEmptyInitialConfiguration" 

    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg" 

    Option "PrimaryGPU" "yes" 

EndSection 
The important line here is PrimaryGPU. I think I had laggy monitors because ubuntu was running everything over the integrated GPU
8. Restart

Hopefully it works.
Wait.. How does it come that you are able to run it with Nvidia drivers. As far as I read, the DisplayLink software will only work with opensource drivers. Is there something new about nvidia-driver-450 and newer, that makes it finally work?
thopiekar is offline   Reply With Quote
Old 10-06-2020, 09:14 PM   #3
vuki656
Junior Member
 
Join Date: Sep 2020
Posts: 2
Default

Quote:
Originally Posted by thopiekar View Post
Wait.. How does it come that you are able to run it with Nvidia drivers. As far as I read, the DisplayLink software will only work with opensource drivers. Is there something new about nvidia-driver-450 and newer, that makes it finally work?
Honestly no idea.

There are a few drawbacks like out-of-scale aspect ratio and night light not working on external monitors but Ill take that any day as long as my external monitors work smoothly.
vuki656 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.