Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-25-2020, 11:43 AM   #1
mackan
Junior Member
 
Join Date: Mar 2020
Posts: 4
Exclamation Battery is not charging after macOS 10.15.4 (Catalina) update

Hi,

Unfortunelly, my DisplayLink has stoppped working properly - my battery is not charging after macOS 10.15.4 (Catalina) update. I have tried installing different versions of DisplayLink drivers (using version 5.2.1 now, it seems to be the most stable one).

Other issues with this update were reported here: https://displaylink.org/forum/showpo...15&postcount=2

Dear Support Team, please investigate it.

Best regards,
Maciej

Last edited by mackan; 03-25-2020 at 11:55 AM.
mackan is offline   Reply With Quote
Old 03-26-2020, 02:08 PM   #2
jefisher
Junior Member
 
Join Date: Nov 2019
Posts: 9
Default

Same here, it no longer charges (the battery icon shows the plugged in but not charging status), but in details it shows it as not charging).

Last edited by jefisher; 03-26-2020 at 02:14 PM.
jefisher is offline   Reply With Quote
Old 03-26-2020, 02:36 PM   #3
jefisher
Junior Member
 
Join Date: Nov 2019
Posts: 9
Default Logs

Here are logs (info and verbose). I can't use the dock anymore until this is fixed.
Attached Files
File Type: zip DisplayLinkInfo_Output_20200326_092504.zip (3.72 MB, 1 views)
File Type: zip DisplayLinkInfo_Output_20200326_093508.zip (3.91 MB, 1 views)

Last edited by jefisher; 03-26-2020 at 02:38 PM.
jefisher is offline   Reply With Quote
Old 03-27-2020, 09:20 AM   #4
mackan
Junior Member
 
Join Date: Mar 2020
Posts: 4
Default

Quote:
Originally Posted by jefisher View Post
Same here, it no longer charges (the battery icon shows the plugged in but not charging status), but in details it shows it as not charging).
Yes, it looks the same on my side. For charging, I have an Apple charger attached too.
mackan is offline   Reply With Quote
Old 03-29-2020, 05:28 AM   #5
Bioprocess
Junior Member
 
Join Date: Mar 2020
Posts: 2
Default

Quote:
Originally Posted by mackan View Post
Yes, it looks the same on my side. For charging, I have an Apple charger attached too.
My Dell D6000 also stopped charging my MacBook after I had updated to Catalina 10.15.4.

I found the fix on Reddit and it worked for me. See the thread here.

The fix is to use a PC to update the D6000's firmware to ver A03.

I hope this works for you all!
Bioprocess is offline   Reply With Quote
Old 03-30-2020, 09:54 PM   #6
jefisher
Junior Member
 
Join Date: Nov 2019
Posts: 9
Default

Quote:
Originally Posted by Bioprocess View Post
My Dell D6000 also stopped charging my MacBook after I had updated to Catalina 10.15.4.

I found the fix on Reddit and it worked for me. See the thread here.

The fix is to use a PC to update the D6000's firmware to ver A03.

I hope this works for you all!
But what do we do if we don't have a PC? \_(ツ)_/
jefisher is offline   Reply With Quote
Old 04-01-2020, 03:33 PM   #7
BrokenMacMan
Junior Member
 
Join Date: Apr 2020
Posts: 1
Default None

What if you download parallels on Mac and run windows 10 to install it? Would that solve the issue ?
BrokenMacMan is offline   Reply With Quote
Old 04-01-2020, 11:18 PM   #8
jefisher
Junior Member
 
Join Date: Nov 2019
Posts: 9
Default

Quote:
Originally Posted by BrokenMacMan View Post
What if you download parallels on Mac and run windows 10 to install it? Would that solve the issue ?
I was using VMWare (and another user was using Parallels) and neither of us could get the firmware to apply. During the update it disconnects and reconnects several times, and each time the device appears new (so the VM will ask you what to attach it to), and it seems in that interim the fw update fails.
jefisher is offline   Reply With Quote
Old 04-15-2020, 09:29 AM   #9
KatarzynaKowalczyk
DisplayLink Tech Support
 
KatarzynaKowalczyk's Avatar
 
Join Date: Apr 2020
Posts: 203
Default

Hello,

Please make sure that you have macOS Catalina 10.15.4 Supplemental Update installed. It has been released just recently and could fix the issues.
Please do not hesitate if you have additional questions.

Best regards,
Katarzyna
KatarzynaKowalczyk is offline   Reply With Quote
Old 06-22-2020, 12:07 PM   #10
gian
Junior Member
 
Join Date: Jun 2020
Posts: 2
Default

Hi,

The battery on my laptop is now not charging:

HTML Code:
$ pmset -g batt
Now drawing from 'AC Power'
 -InternalBattery-0 (id=8650851)	46%; AC attached; not charging present: true
I have a (13-inch, 2017, Four Thunderbolt 3 Ports)
maOS Catalina 10.15.5

com.displaylink.DisplayLinkDriver
Version: 5.2.4 (82)

DELL UNIVERSAL DOCK - D6000

See screenshot of battery just draining but the mac is connected to the DisplayLink
Attached Images
File Type: jpg Screenshot 2020-06-22 at 12.06.36.jpg (13.0 KB, 2 views)
gian is offline   Reply With Quote
Reply

Tags
10.15.4, catalina, displaylink, macos

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.