Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-23-2020, 07:48 PM   #1
triplemaya
Junior Member
 
Join Date: Feb 2019
Posts: 5
Default 1 second lag

New install of ubuntu mate 20.04
installed displaylink with
displaylink-driver-5.3.1.34.run
install goes fine
Monitor is connected to docking station with displayport cable.

PROBLEM
key presses and mouse clicks take about one second to register. So the system is unusable.
Mouse movement is fine

This is only the case when the large monitor is set to primary and the laptop screen is off. When the system is running with two monitors there is no problem.
This configuration works perfectly when laptop is directly connected to large display with displayport cable.

Symptom present on three different docking stations, so not a hardware issue there.
All versions of hardware working perfectly in this configuration with ubuntu mate 18.04

Last edited by triplemaya; 07-25-2020 at 04:17 PM. Reason: Further information added
triplemaya is offline   Reply With Quote
Old 08-21-2020, 11:26 PM   #2
billkoolguy
Junior Member
 
Join Date: Aug 2020
Posts: 1
Default Bug Fix

There is a patch released to fix this on Ubuntu 20

https://github.com/DisplayLink/evdi/issues/181 thread of others with same issue

https://www.displaylink.org/forum/sh...ad.php?t=67148 patch link

I still need the patch for 18, so same problem for me needing to keep the primary display on....
billkoolguy is offline   Reply With Quote
Old 08-22-2020, 09:20 AM   #3
triplemaya
Junior Member
 
Join Date: Feb 2019
Posts: 5
Default

Hi Bill

Many thanks for this. A googled a lot but did not find the jan logged bug on github.

Works perfect now.

Very bad luck if you have the problem with 18. My 18.04 MATE installations run just fine.

Andrew
triplemaya is offline   Reply With Quote
Old 09-11-2020, 06:30 PM   #4
thopiekar
Junior Member
 
Join Date: Sep 2020
Posts: 6
Default

Quote:
Originally Posted by billkoolguy View Post
There is a patch released to fix this on Ubuntu 20

https://github.com/DisplayLink/evdi/issues/181 thread of others with same issue

https://www.displaylink.org/forum/sh...ad.php?t=67148 patch link

I still need the patch for 18, so same problem for me needing to keep the primary display on....
Very useful. I'll look into this and see whether we can't make any use of the patch in an easy way

However, I'll only put focus on Ubuntu 20.04 (or whatever I run at the moment).
thopiekar is offline   Reply With Quote
Old 09-11-2020, 07:47 PM   #5
triplemaya
Junior Member
 
Join Date: Feb 2019
Posts: 5
Default

Works perfectly out of the box on 20.04
triplemaya is offline   Reply With Quote
Old 09-11-2020, 08:22 PM   #6
thopiekar
Junior Member
 
Join Date: Sep 2020
Posts: 6
Default

Quote:
Originally Posted by triplemaya View Post
Works perfectly out of the box on 20.04
You mean DisplayLink's patched package? I'm not sure how their changes influence other packages which are built from the same source. Nevertheless, I'll add it to my PPA next to the evdi packages.
thopiekar is offline   Reply With Quote
Old 09-12-2020, 10:50 AM   #7
triplemaya
Junior Member
 
Join Date: Feb 2019
Posts: 5
Default

I mean the XServer Patch

DisplayLink XServer Patch (20.04)

https://www.displaylink.com/downloads/file?d=310

And certain updates overwrite it so you have to do it again.
triplemaya is offline   Reply With Quote
Old 09-14-2020, 08:42 AM   #8
Zajic
Junior Member
 
Join Date: Jul 2018
Posts: 5
Default

I can't recommend this patch. After patch it caused xorg-server as very unstable and crashing for me (i have fresh install Linux Mint Mate). (https://gitlab.freedesktop.org/mesa/mesa/-/issues/3468) I only install last xorg-server from update center + my laptop display stayed as active.

After return back to lastest xorg-server it seems all fine. But yes, laptop display is still not fixed (https://gitlab.freedesktop.org/xorg/.../-/issues/1028). Keep your laptop display turned on.


I will wait for any proper displaylink version + xorg. It's a shame.

Last edited by Zajic; 09-14-2020 at 08:46 AM.
Zajic is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.