Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-11-2018, 05:11 AM   #1
lenovouser
Junior Member
 
Join Date: Nov 2018
Posts: 1
Question skewed rotated distorted image

hello - I am using the displaylink-rpm for Fedora on a Dell XPS13 with a Lenovo LT1421. I haven't used the USB screen for a few months and updated to the latest Fedora 29 recently. I compiled and installed the latest displaylink-rpm.

The driver seems to be working well except that the image is massively distorted. I have posted the issue on github with evdi and would like to point to it in case someone experience anything in kind

https://github.com/DisplayLink/evdi/...ment-437601509



lenovouser is offline   Reply With Quote
Old 11-29-2018, 06:41 AM   #2
cacarr
Junior Member
 
Join Date: Oct 2017
Posts: 12
Default

I had something like that as well, after an update to 4.4.24-1. Had to remove an evdi.conf config that I had used to enable rotation/portrait orientation. Sadly, vertical orientation no longer works for me, and I have severe mouse pointer artifacts.

Urgh.
cacarr is offline   Reply With Quote
Old 05-29-2019, 09:07 PM   #3
jei
Junior Member
 
Join Date: May 2019
Posts: 1
Default

I have a similar issue with an AOC E1659Fwu. I use Fedora 30 (KDE) and the rpm package from https://github.com/displaylink-rpm/displaylink-rpm: evdi 1.6.1 (displaylink-rpm v5.1.26-1).

Code:
$ uname -r
5.0.16-300.fc30.x86_64
First, I get a similar distorted image when using the native resolution of 1366x768:


This is the image the screen is supposed to show:


When I use a lower resolution like 1024x768, the screen works just fine:


I took the above pictures while the screen was connected to a HP EliteBook 2760p via USB 2.0, but I could reproduce this issue on a similar setup with a ThinkPad T440p (Fedora 30 as well) using USB 3.0.

On both systems, the distortion did not occur a few month ago (when I was on Fedora 28).

A second issue I noticed on both systems is a flickering cursor on the primary (non-DisplayLink) screen, which is rather annoying. I tried to capture it on a video: https://vimeo.com/339206961


Any help would be highly appreciated!

— Jan

Last edited by jei; 05-29-2019 at 09:10 PM.
jei is offline   Reply With Quote
Reply

Tags
distorted, image, problem, rotated, skewed

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.