Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-27-2018, 02:19 PM   #1
freematt
Junior Member
 
Join Date: Dec 2018
Posts: 3
Default Dell D6000 Dock DisplayPort output not recognized

Equipment
Dell D6000 Dock USB-C
Dell 15in XPS 9570

Iíve installed Ubuntu LTS18.04 on this unit(because I despise the newer Windows OSís). along with installed the DisplayLink drivers. But I am getting lost in different articles/forum posts asking to run different commands that may or may not be the same issue. I can start my XPS and boot into Ubuntu however neither DisplayPort monitors come on or activate. I have over the holiday been able to do additional testing and discovered the HDMI connector does register and activate to extend the desktop without issue. The USB ports and Ethernet adapters also work, which leaves the 2 DisplayPort connectors as the problem issue. (I should also note that before I changed OSís the DisplayPortís did work so I know it must be a driver issue.

Hopefully someone may have had a similar issue and fix or a few commands/outputs I should run to provide a better understanding of the issue would be extremely helpful.

Thanks in Advance for any help!
freematt is offline   Reply With Quote
Old 01-08-2019, 11:06 AM   #2
mlukaszek
Senior Member
 
mlukaszek's Avatar
 
Join Date: Feb 2010
Posts: 383
Default

Can you post logs captured by our support tool?

Thanks
Michal
mlukaszek is offline   Reply With Quote
Old 01-09-2019, 02:42 AM   #3
jgleicher
Junior Member
 
Join Date: Jan 2019
Posts: 2
Default Log Files

I'm not the original poster, but I was coming here to post the exact issue with my newly-installed Ubuntu 18.04 machine with the D6000 Dock (different computer hardware though than the OP).

Attached is the support dump.

I've done moderate troubleshooting over the last few days, but am not able to get the Display Port monitors to function (I did not experiment with the HDMI port as the original poster did). The dock works as I use it on a Window 10 laptop, as well as another Ubuntu 18.04 laptop (that is not a new-install, but has been upgraded through a number of LTS versions over the years).

If this reply is inappropriate, please let me know and I'll move to my own dedicated post.
Attached Files
File Type: zip DLSupportTool_Output_2019-01-08T21:07:34.706254.zip (364.3 KB, 1 views)
jgleicher is offline   Reply With Quote
Old 01-10-2019, 01:43 PM   #4
freematt
Junior Member
 
Join Date: Dec 2018
Posts: 3
Default

I have attached the output from this morning. This is the current setup with the dock connected to 2 displayport monitors. If you would like additional for HDMI let me know please.

Thank You,
Matt
Attached Files
File Type: zip DLSupportTool_Output_2019-01-10T09:39:50.164009.zip (32.4 KB, 1 views)
freematt is offline   Reply With Quote
Old 01-11-2019, 10:00 AM   #5
mlukaszek
Senior Member
 
mlukaszek's Avatar
 
Join Date: Feb 2010
Posts: 383
Default

Quote:
Originally Posted by freematt View Post
I have attached the output from this morning.
Hi Matt,

You have secure boot enabled, and this is the reason why our evdi kernel module cannot be loaded. Please read https://support.displaylink.com/know...-with-uefi-sec

Thanks!
Michal
mlukaszek is offline   Reply With Quote
Old 01-15-2019, 01:16 PM   #6
freematt
Junior Member
 
Join Date: Dec 2018
Posts: 3
Cool

Quote:
Originally Posted by mlukaszek View Post
Hi Matt,

You have secure boot enabled, and this is the reason why our evdi kernel module cannot be loaded. Please read https://support.displaylink.com/know...-with-uefi-sec

Thanks!
Michal
Thank you Michal! i thought i had it disabled but sure enough as soon as i disabled it and rebooted both monitors come on without an issue. Thank you for the assistance!
freematt is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.