Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-30-2024, 01:46 PM   #1
billfanning603
Junior Member
 
Join Date: Jan 2024
Posts: 1
Exclamation DisplayLink Manager 1.10 is closing/crashing

Hi all,

I am using a Mac with OS Sonoma 14.2.1 and DL Manager 1.10.0 Build 117 and for some reason the system is now not connecting when I turn on or dock my Mac. I end up plugging and unplugging my system over and over, and restarting DL over and over and sometimes it clicks, and sometimes it does not.

So the question is - what changed? Is the OS or the new DL version causing this?

and for fun...

How the heck do I resolve this issue?????
billfanning603 is offline   Reply With Quote
Old 01-30-2024, 03:56 PM   #2
NNV
Junior Member
 
Join Date: Jan 2024
Posts: 4
Default

Same issue is happening to me. Just stopped working yesterday. Same OS and DisplayLink Manager version as you.
NNV is offline   Reply With Quote
Old 01-31-2024, 05:45 AM   #3
anupsahu
Junior Member
 
Join Date: Jan 2024
Posts: 4
Default Same issue

Same issue for me too. It has stopped working completely. It is unable to detect my monitor

Last edited by anupsahu; 01-31-2024 at 05:42 PM.
anupsahu is offline   Reply With Quote
Old 01-31-2024, 07:44 AM   #4
cpl
Junior Member
 
Join Date: Jan 2024
Posts: 1
Default

Same here ... Do we have any solution to get an old version of the driver ?
cpl is offline   Reply With Quote
Old 01-31-2024, 10:53 AM   #5
rboerner
Super Moderator
 
Join Date: Jan 2015
Posts: 448
Default

If you are encountering unexpected behavior while using a product based on DisplayLink technology and the manufacturer of the original product has not been able to assist you, then the issue can be reported to DisplayLink directly by following the process outlined here --> https://support.displaylink.com/know...to-displaylink
rboerner is offline   Reply With Quote
Old 01-31-2024, 05:41 PM   #6
anupsahu
Junior Member
 
Join Date: Jan 2024
Posts: 4
Default

Done send details. Hoping for a quick resolution. I am sure there are more people like us
anupsahu is offline   Reply With Quote
Old 02-08-2024, 03:25 AM   #7
mixresults
Junior Member
 
Join Date: Feb 2024
Posts: 1
Angry 3rd monitor stopped working

My 3rd monitor stopped working recently, and I did do a Sonoma update but worked for at least a week but it was buggy. It is the monitor using the HDMI-only port. Really hope this gets sorted soon.
mixresults is offline   Reply With Quote
Old 02-09-2024, 03:41 PM   #8
zubyh
Junior Member
 
Join Date: Feb 2024
Posts: 1
Default

Quote:
Originally Posted by mixresults View Post
My 3rd monitor stopped working recently, and I did do a Sonoma update but worked for at least a week but it was buggy. It is the monitor using the HDMI-only port. Really hope this gets sorted soon.
Exactly the same happened for me, only the HDMI monitor stopped, other two displayport ones work
zubyh is offline   Reply With Quote
Old 02-12-2024, 07:03 AM   #9
christian@hunewald.de
Junior Member
 
Join Date: Feb 2024
Posts: 2
Default Same issue with upgrade to 14.3.1

Just installed Mac OS 14.3.1. After installation Displaylink not working anymore. I uninstalled displayling and installed it again - does not work. please help.
christian@hunewald.de is offline   Reply With Quote
Old 02-12-2024, 07:10 AM   #10
christian@hunewald.de
Junior Member
 
Join Date: Feb 2024
Posts: 2
Default Possible workaround

Hi, what I just tried, and it worked, not sure if this is sustainable:

- deactivated screen recording in system privacy settings
- activated scrreen recording
- turned off my displaylink device (startech)
- restart
- waited until displaylink software running
- turned on displaylink device startech
after a few seconds additional screens appeared
christian@hunewald.de is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.