Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-19-2022, 05:09 PM   #1
domehead100
Junior Member
 
Join Date: Sep 2022
Posts: 4
Default Trying to get DL working on NixOs

I'm on Linux but on NixOS (not Ubuntu). I'm trying to get DisplayLink working in order to drive more displays than the limit of 4 provided by the integrated GPU on my laptop.

xrandr --listproviders does not show the DisplayLink provider. The second provider is the Nvidia GPU.
Code:
$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x48 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 10 associated providers: 0 name:modesetting
Provider 1: id: 0xc9 cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:modesetting
As a note, this is an HP ZBook Power G9 laptop with an Intel i7-12700H CPU and an Nvidia T600 discrete GPU, but the Nvidia GPU apparently only functions in Optimus/Prime mode so I'm limited to the 4 displays provided by the Intel GPU.

As a further note, I actually have 2 docks (all displays are 1080p):
  • HP Thunderbolt 280W Dock G4 (off of which the laptop screen and 3 external monitors are being driven)
  • An HP Universal USBC/A Dock G2 (which uses DisplayLink and is what I'm trying to set up to drive 2 or 3 additional displays)

Using the fwupdmgr utility (used for updating firmware), I see the following for the DisplayLink dock:

Code:
─HP USB-C Universal Docking Station:
│ Device ID: fc6da820357c954f813bc50790f9ea7fbf0aed9b
│ Current version: 31.2
│ Vendor: DisplayLink (USB:0x17E9)
│ Serial Number: 43A5B830EEA
│ GUIDs: 3a11c4a7-a4a8-5cfc-b9aa-047dfb15f21e ← USB\VID_17E9&PID_601E
│ 3ac5f23c-a246-5799-a372-ecba091ee7e4 ← USB\VID_17E9&PID_601E&REV_3102
│ Device Flags:  Updatable
In trying to get some driver working, I think that I need to be sure of the DisplayLink chipset family to ensure that I get a compatible driver, plus just curious.

I assume that it is a DL-6000 series, but if not then I assume that someone here can tell me what it is based on the PID_601E and the REV_3102?

As far as troubleshooting...
  • The DisplayLink Manager service is running and looks to be version 5.6.0-59.176
    Code:
    [mike@mike-lap:~]$ systemctl status dlm.service
    ● dlm.service - DisplayLink Manager Service
         Loaded: loaded (/etc/systemd/system/dlm.service; linked; preset: enabled)
         Active: active (running) since Sun 2022-09-18 17:12:04 EDT; 19h ago
       Main PID: 1243 (.DisplayLinkMan)
             IP: 0B in, 0B out
             IO: 8.7M read, 8.0K written
          Tasks: 9 (limit: 76718)
         Memory: 10.5M
            CPU: 7.295s
         CGroup: /system.slice/dlm.service
                 └─1243 /nix/store/h683vb4117fnsh8kwirgnr9dpy9cv1l8-displaylink-5.6.0-59.176/bin/DisplayLinkManager
  • The DisplayLink Manager log in /var/log/displaylink/DisplayLinkManager.log seems to be encrypted, so I can't view it. Is there some way to view that log?
domehead100 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.