Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-09-2021, 03:31 PM   #1
leetuckert
Junior Member
 
Join Date: Nov 2021
Posts: 1
Default Ubuntu 20.04 Software Update Killed Displaylink

So, being prompted this morning by Ubuntu 20.04, to do a software update, I stupidly agreed. It was of those that required a reboot. Upon reboot, my Displaylink device is completely broken. I removed the driver and reinstalled. No help. I removed the driver, downloaded the latest from Displaylink, installed it but, no help. The displaylink service shows up as dead. I can restart it and systemctl status shows that it is alive and running. However, lsusb does not show the evdi loaded. So, I am back to a single monitor. Anyone else having this problem today?
leetuckert is offline   Reply With Quote
Old 11-17-2021, 08:37 PM   #2
caitifty
Junior Member
 
Join Date: May 2020
Posts: 4
Default Kernel update killed displaylink

Same problem - regular update updated kernel from 5.55.0-38 to 5.11.0-40 which stopped displaylink recognizing external monitors completely.

Only solution which worked was to force grub to load the previous kernel. Instructions for that here: https://www.systutorials.com/how-to-...-ubuntu-20-04/
caitifty is offline   Reply With Quote
Old 11-19-2021, 08:28 PM   #3
pjones1063
Junior Member
 
Join Date: Nov 2021
Posts: 2
Default Ubuntu 20.04 Software Update Killed Displaylink

I have the same issue. It wont run at all with 5.11.0-40. The installer actually fail with 5.11.0-40 running. Had to reinstall it with 5.55.0-38 running. Below is error in the kernel ring buffer - dmesg when 5.11.0-40 is up:


[ 30.391112] module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 1, loc 000000004e8c48c2, val ffffffffc14c3d80
[ 30.516312] module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 1, loc 000000009acc30c1, val ffffffffc14e1d80

Hope this gets corrected soon. Its a drag use in older kernel.
pjones1063 is offline   Reply With Quote
Old 12-14-2021, 01:49 AM   #4
pjones1063
Junior Member
 
Join Date: Nov 2021
Posts: 2
Default Bounce

I am sure others are having this issue on Ubuntu. No updates at all?
pjones1063 is offline   Reply With Quote
Old 12-18-2021, 06:24 PM   #5
jefcap
Junior Member
 
Join Date: Dec 2021
Posts: 2
Default DisplayLink is unstable in ubuntu 20.04 after kernel 5.11.0-38

Noticed the usb connection drop after ~1hr usage. I could collect the logs using DLSupportTool (https://synaptics.com/products/displ...x-support-tool).
Noticed the following errors in dmesg associated to usb connection:

[ 1473.657317] usb 2-1.1: Disable of device-initiated U1 failed.
[ 1473.668280] usb 2-1.1: Disable of device-initiated U2 failed.
[ 1473.668385] cdc_ncm 2-1.1:1.5 enx0c379621a317: unregister 'cdc_ncm' usb-0000:00:14.0-1.1, CDC NCM
[ 1473.723868] usb 2-1.1: Set SEL for device-initiated U1 failed.
[ 1473.730972] usb 2-1.1: Set SEL for device-initiated U2 failed.
[ 1474.065826] usb 2-1.1: reset SuperSpeed Gen 1 USB device number 7 using xhci_hcd
[ 1474.101742] usb 2-1.1: Warning! Unlikely big volume range (=767), cval->res is probably wrong.
[ 1474.101746] usb 2-1.1: [4] FU [Mic Capture Volume] ch = 2, val = -4592/7680/16
[ 1474.102340] usb 2-1.1: Warning! Unlikely big volume range (=672), cval->res is probably wrong.

Please verify the root cause of it. Full logs attached.
Attached Files
File Type: zip DLSupportTool_Output_2021-12-18T16:08:11.643608.zip (645.0 KB, 0 views)
jefcap is offline   Reply With Quote
Old 12-20-2021, 10:38 AM   #6
snipe122
Junior Member
 
Join Date: Feb 2019
Posts: 27
Default

Also experiencing connection drops, after some hours usage usually, connection is restored after some seconds.

Running 21.10 with latest updates (5.13.0-22-generic #22-Ubuntu SMP Fri Nov 5 13:21:36 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux).

I didn't upgrade / re-install Displaylink so I suspect some change in Kernel / some driver is causing this behavior. Having similar messages as @jefcap in the dmesg.
snipe122 is offline   Reply With Quote
Old 03-18-2022, 09:26 PM   #7
jefcap
Junior Member
 
Join Date: Dec 2021
Posts: 2
Thumbs down up

Serious? No support since last year?
jefcap is offline   Reply With Quote
Old 03-21-2022, 10:57 AM   #8
snipe122
Junior Member
 
Join Date: Feb 2019
Posts: 27
Default

I had a support ticket open and it was promised that a fix would be in 5.5 release. Unfortunately it's still an issue. I have replied back to the support but since that I did not hear anything positive.
snipe122 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.