Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-04-2021, 10:37 PM   #1
mmehl
Junior Member
 
Join Date: Aug 2021
Posts: 5
Default Ubuntu 21.04: could not insert 'evdi': Exec format error

Hi all,

I'm not able to use my monitor via DisplayLink on Ubuntu 21.04.

I installed "DisplayLink USB Graphics Software for Ubuntu5.4-EXE.zip"
It seems the evdi module is not loaded by the kernel.

I see the following errors in syslog:
Code:
Aug  4 18:48:25 mZBOX systemd[1]: displaylink-driver.service: Scheduled restart job, restart counter is at 357.
Aug  4 18:48:25 mZBOX systemd[1]: Stopped DisplayLink Driver Service.
Aug  4 18:48:25 mZBOX systemd[1]: Starting DisplayLink Driver Service...
Aug  4 18:48:25 mZBOX kernel: [ 2015.120007] module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 1, loc 00000000b1e3d105, val ffffffffc1e48e3e
Aug  4 18:48:25 mZBOX sh[45704]: modprobe: ERROR: could not insert 'evdi': Exec format error
Aug  4 18:48:25 mZBOX sh[45730]: Module evdi/1.9.1 already installed on kernel 5.11.0-25-generic/x86_64
Aug  4 18:48:25 mZBOX kernel: [ 2015.349287] module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 1, loc 000000006a9a04e2, val ffffffffc1e60e3e
Aug  4 18:48:25 mZBOX sh[45705]: modprobe: ERROR: could not insert 'evdi': Exec format error
Aug  4 18:48:25 mZBOX systemd[1]: displaylink-driver.service: Control process exited, code=exited, status=1/FAILURE
Aug  4 18:48:25 mZBOX systemd[1]: displaylink-driver.service: Failed with result 'exit-code'.
Aug  4 18:48:25 mZBOX systemd[1]: Failed to start DisplayLink Driver Service.
Some details about my configuration:

Code:
uname -a
Linux mZBOX 5.11.0-25-generic #27-Ubuntu SMP Fri Jul 9 23:06:29 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
If you need more details, I'll be happy to provide them.
mmehl is offline   Reply With Quote
Old 08-05-2021, 08:17 AM   #2
barter
Junior Member
 
Join Date: Aug 2021
Posts: 5
Default

Please run the installer with uninstall param, this will get rid of the evdi you had installer previously:

Quote:
Aug 4 18:48:25 mZBOX sh[45730]: Module evdi/1.9.1 already installed on kernel 5.11.0-25-generic/x86_64
and then reboot, and run installer again. It should be fine from there. It was for me
barter is offline   Reply With Quote
Old 08-05-2021, 10:31 AM   #3
mmehl
Junior Member
 
Join Date: Aug 2021
Posts: 5
Default

Thanks for this hint. I tried this already several times, but it does not solve the problem.
mmehl is offline   Reply With Quote
Old 08-05-2021, 04:47 PM   #4
barter
Junior Member
 
Join Date: Aug 2021
Posts: 5
Default

ok, so if you still have another evdi loaded, can you make sure you do not have `evdi-dkms` installed and then repeat uninstall + install procedure?
barter is offline   Reply With Quote
Old 08-05-2021, 05:58 PM   #5
mmehl
Junior Member
 
Join Date: Aug 2021
Posts: 5
Default

This was one of my tests when I had the problem with DisplayLink: I installed evdi-dkms, but this also failed when I tried "modprobe evdi".

I removed evdi-dkms, but the problem with DisplayLink remains.

Package status is not "installiert":
Code:
mmehl@mZBOX:~$ apt list evdi-dkms
Auflistung… Fertig
evdi-dkms/hirsute,hirsute 1.9.1-1ubuntu1 all
mmehl is offline   Reply With Quote
Old 08-06-2021, 08:28 AM   #6
barter
Junior Member
 
Join Date: Aug 2021
Posts: 5
Default

I know it is not helping but decided to post this anyway.
I have checked the same kernel you have installed and I can reproduce the same issue you have posted. So I'd say this is a bug that needs to be reported.
barter is offline   Reply With Quote
Old 08-10-2021, 01:22 AM   #7
max1
Junior Member
 
Join Date: Aug 2021
Posts: 1
Angry Similar Issue

Hello,

I am having a similar issue with my Dell D6000 that uses DisplayLink on Pop OS 21.4....
I get the 5.4 driver for ubuntu instaled just fine and I can get 2 monitors through the dock to work up until I change one of their orientations then the system crashes.. or sometimes they do not connect at all and the system crashes right away.

Any headway with your issue?

Thank You!



Quote:
Originally Posted by mmehl View Post
Hi all,

I'm not able to use my monitor via DisplayLink on Ubuntu 21.04.

I installed "DisplayLink USB Graphics Software for Ubuntu5.4-EXE.zip"
It seems the evdi module is not loaded by the kernel.

I see the following errors in syslog:
Code:
Aug  4 18:48:25 mZBOX systemd[1]: displaylink-driver.service: Scheduled restart job, restart counter is at 357.
Aug  4 18:48:25 mZBOX systemd[1]: Stopped DisplayLink Driver Service.
Aug  4 18:48:25 mZBOX systemd[1]: Starting DisplayLink Driver Service...
Aug  4 18:48:25 mZBOX kernel: [ 2015.120007] module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 1, loc 00000000b1e3d105, val ffffffffc1e48e3e
Aug  4 18:48:25 mZBOX sh[45704]: modprobe: ERROR: could not insert 'evdi': Exec format error
Aug  4 18:48:25 mZBOX sh[45730]: Module evdi/1.9.1 already installed on kernel 5.11.0-25-generic/x86_64
Aug  4 18:48:25 mZBOX kernel: [ 2015.349287] module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 1, loc 000000006a9a04e2, val ffffffffc1e60e3e
Aug  4 18:48:25 mZBOX sh[45705]: modprobe: ERROR: could not insert 'evdi': Exec format error
Aug  4 18:48:25 mZBOX systemd[1]: displaylink-driver.service: Control process exited, code=exited, status=1/FAILURE
Aug  4 18:48:25 mZBOX systemd[1]: displaylink-driver.service: Failed with result 'exit-code'.
Aug  4 18:48:25 mZBOX systemd[1]: Failed to start DisplayLink Driver Service.
Some details about my configuration:

Code:
uname -a
Linux mZBOX 5.11.0-25-generic #27-Ubuntu SMP Fri Jul 9 23:06:29 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
If you need more details, I'll be happy to provide them.
max1 is offline   Reply With Quote
Old 08-15-2021, 10:16 AM   #8
mmehl
Junior Member
 
Join Date: Aug 2021
Posts: 5
Default Issue added to evdi project

I've now created an issue in the evdi project:
see https://github.com/DisplayLink/evdi/issues/301
mmehl is offline   Reply With Quote
Old 08-22-2021, 10:11 PM   #9
mmehl
Junior Member
 
Join Date: Aug 2021
Posts: 5
Default Problem fixed

Problem is fixed. Kernel 5.11.0-31-generic is now available and works as expected.
mmehl is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.