Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-13-2021, 05:56 PM   #1
mauromol
Junior Member
 
Join Date: Mar 2015
Posts: 7
Unhappy Audio over HDMI: is it supposed to work?

I installed DisplayLink driver version 5.4 on Kubuntu 20.04. Video is working fine (apart from the usual problem of the high CPU usage of DisplayLinkManager process), but...

After driver installation, there's now a new audio device on my system, called "USB3.0 Dual Video Dock". For this device I can choose among a lot of different profiles, like analog stereo output, analog stereo duplex, IEC958 digital output, IEC958 digital duplex, some analog surround outputs, etc..
However, whatever I choose, the audio does not reach my monitor via the HDMI cable (yes, my monitor has built-in speakers...).

Please note, I'm not talking about the analog jack output on the docking station (which I never tested and not interested in), but rather about audio through the HDMI connection between the docking station and the monitor.

Is it supposed to work at all? Reading from other messages over the Internet, it seems like so...

The main annoyance is that Kubuntu is often turning this "USB3.0 Dual Video Dock" audio device as the system default one, hence I get no sound at all when it happens, unless I force one of the other audio devices to be back the default one.

Thanks in advance.
mauromol is offline   Reply With Quote
Old 09-28-2021, 11:27 AM   #2
mauromol
Junior Member
 
Join Date: Mar 2015
Posts: 7
Default

Does anyone know the answer to my original question?

This problem is particularly annoying because whenever the display goes off due to inactivity, in dmesg I see this entry:

Code:
evdi: [D] evdi_painter_dpms_notify:715 (dev=1) Notifying dpms mode: 3
When this happens, it seems like there's some sort of "unpluggin" and "re-plugging" of the "USB3.0 Dual Video Dock" audio device. In Kubuntu the net effect is this:
  • if I had turned that device off, it turns back on
  • having that device being turned back on causes it to be set as the default system audio device
  • as a consequence of the previous point, if I'm using a communication application and talking with my Bluetooth headset when the screen goes black, suddenly I don't hear anything any more because the audio stream is switched by pulse audio to the "USB3.0 Dual Video Dock", which does not emit any sound through my monitor and hence I get no sound at all for my ongoing call...

Anyone experiencing similar effects?
mauromol is offline   Reply With Quote
Reply

Tags
hdmi audio

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.