Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-25-2019, 09:37 AM   #1
rich-e-rich
Junior Member
 
Join Date: Jan 2019
Posts: 2
Default Ubuntu 18.04.1 LTS - DVI & HDMI 2k not working

Hi There,

First off, thanks for taking the time to read this.

A note on my setup:
this docking station: https://plugable.com/products/ud-ultcdl
with this laptop: https://www.lenovo.com/gb/en/p/20L5C...e7&options_11= (note intel graphics card)
running Ubuntu 18.04.1 LTS - 100% up to date from the stand repositories

What happens:
I plug the usb-c into the power of my laptop everything is fine through the 4k HDMI adapter but the 2K adapter and the DVI adapter are not working at all. No monitors are detected when using these 2 adapters.

I've been advised by Plugable.com support: "The UD-ULTCDL utilizes DisplayLink drivers and internal chipsets to power the 2K HDMI and DVI port. The 4K HDMI connection and power delivery utilizes unique features of your USB-C port called Alt-Mode and Power Delivery. "

I've tried a few things already, including Plugable.com's own support script to install the latest DisplayLink drivers on a Debian based system, however this did not have any noticeable effect.

Attached is my output from your support tool.

Any advice greatly appreciated
Attached Files
File Type: zip DLSupportTool_Output_2019-01-25T09:43:32.497687.zip (29.6 KB, 0 views)
rich-e-rich is offline   Reply With Quote
Old 02-04-2019, 08:57 AM   #2
rich-e-rich
Junior Member
 
Join Date: Jan 2019
Posts: 2
Default it fixed itself?!

So after the original post, i pretty much gave up on the idea of having 2 hdmi monitors coming out of my dock. Several days have passed and literally nothing has changed to my knowledge.

I connected the dock as usual this morning, so i could use the hdmi 4k adapter, and i noticed that the audio options were listing a new output device: "Digital Output (S/PDIF) - Plugable UD-ULTCDL" & "Analogue Output.." -- this has happened once before, i'm sure. So i connected a second spare monitor from my office to the hdmi 2k adapter and it worked.

Voila, dual screen again...

I've attached another round of support tool output for anyone who has the knowledge or patience to cross reference them - i would love to know _what_ made the difference!

TLDR; something clicked today, as it started working without any new input from me. see file attached.

\_(ツ)_/
Attached Files
File Type: zip DLSupportTool_Output_2019-02-04T09:47:51.527603.zip (231.2 KB, 0 views)
rich-e-rich is offline   Reply With Quote
Reply

Tags
lenovo, plugable ud-ultcdl, ubuntu 18.04

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.