Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-11-2019, 06:23 AM   #1
svenh
Junior Member
 
Join Date: Nov 2019
Posts: 3
Default DisplayLink mirroring/extended mix after Catalina Update

Hi,

I have a 2014 Mac Mini with 3 FullHD displays attached (HDMI, DP and one attached via Dual Display USB3 adapter using the HDMI). Mac OS is upgraded to 10.15.1.

The DisplayLink connected display mirrors the contents of the HDMI display but the mouse behaves like it is on an extended display (I can move the mouse across the screen like on an extended display and wiggle it to make the mouse pointer bigger). Mac OS even opens programs on the "extended" display that can't be seen or used.

The kext (5.2.54) is loaded, DisplayLinkUserAgent has permissions in Screen Recording and Accessibility (Bedienungshilfen).

I tried:
I reinstalled the 5.2.1b3 DisplayLink drivers.
I downgraded them to 5.1.1 (and reinstalled 5.2.1b3 after the display didn't even start).
I started recovery mode and rebuilt the system cache.
Nothing helped.

Best
Sven
svenh is offline   Reply With Quote
Old 11-14-2019, 06:23 AM   #2
lspintzyk
Member
 
lspintzyk's Avatar
 
Join Date: Feb 2013
Posts: 63
Default

Sven,
Please gather logs using that tool:
https://www.displaylink.com/downloads/file?d=66
lspintzyk is offline   Reply With Quote
Old 11-17-2019, 09:23 AM   #3
svenh
Junior Member
 
Join Date: Nov 2019
Posts: 3
Default

Here is the log file.
Attached Files
File Type: zip DisplayLinkInfo_Output_20191111_065523.zip (1.96 MB, 3 views)
svenh is offline   Reply With Quote
Old 11-18-2019, 02:08 PM   #4
aklausing
Junior Member
 
Join Date: Nov 2019
Posts: 1
Default

Hi,

I have exactly the same issue with the following setup and 5.2.1 Beta 3:

MBP mid 2015
- Internal Display
- Two external FHD Displays connected via Display Link Docking Station

I uninstalled Beta 3 and went back to Beta 2. With Beta 2 the error is not existing in my envirnoment.

Best Regards,
Andreas Klausing
aklausing is offline   Reply With Quote
Old 11-20-2019, 06:38 AM   #5
lspintzyk
Member
 
lspintzyk's Avatar
 
Join Date: Feb 2013
Posts: 63
Default

Svenh
I was analyzing your logs, but all looks fine.
Can you test yours setup with 5.2.1 beta 2 as aklausing did?
That would help me to identify the problem.

You can download it from here:
https://www.displaylink.com/downloads/file?id=1433
lspintzyk is offline   Reply With Quote
Old 11-22-2019, 12:48 PM   #6
lspintzyk
Member
 
lspintzyk's Avatar
 
Join Date: Feb 2013
Posts: 63
Default

Quote:
Originally Posted by svenh View Post
Here is the log file.
Can you also submit output of command:
ioreg -l > ioreg.txt

I would really appreciate that
lspintzyk is offline   Reply With Quote
Old 12-08-2019, 02:20 PM   #7
svenh
Junior Member
 
Join Date: Nov 2019
Posts: 3
Default

Hi Andreas,

Beta 2 did the trick. All displays are working again.
Thank you!

Thank you too, lspintzyk!

Best
Sven
svenh is offline   Reply With Quote
Old 12-08-2019, 11:28 PM   #8
jmdorn
Junior Member
 
Join Date: Dec 2019
Posts: 2
Default Having same issues - Beta 2 didn't work

I'm having a similar issue. I've updated to Mac 10.15.1 and Beta 2 but my monitors aren't working. USB ports on dock are dorking just fine
jmdorn is offline   Reply With Quote
Old 12-08-2019, 11:45 PM   #9
jmdorn
Junior Member
 
Join Date: Dec 2019
Posts: 2
Default

I fixed the issue on my own
jmdorn is offline   Reply With Quote
Old 12-13-2019, 05:04 PM   #10
TinWhisker
Junior Member
 
Join Date: Dec 2019
Posts: 1
Default

Quote:
Originally Posted by svenh View Post
The DisplayLink connected display mirrors the contents of the HDMI display but the mouse behaves like it is on an extended display (I can move the mouse across the screen like on an extended display and wiggle it to make the mouse pointer bigger). Mac OS even opens programs on the "extended" display that can't be seen or used.
It appears that this issue has returned for 10.15.2 - same symptoms of mouse can access across both displays, but image is mirror of display #1.

Spec:
- iMac 14,2
- HP USB 2.0 Docking Station (HP HSTNN-S02X)
- Driver 5.2.1 release


However, I did the cheeky thing of finding the "DisplayLink Manager" alpha 0.1 and it works perfectly!
As I can't see it mentioned/linked elsewhere - i wont link it.

Last edited by TinWhisker; 12-13-2019 at 05:15 PM. Reason: Found a fix
TinWhisker is offline   Reply With Quote
Reply

Tags
catalina, displaylink broken, mirroring

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.