Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-28-2021, 03:44 PM   #1
SWP Sebastian
Junior Member
 
Join Date: Jan 2021
Posts: 1
Default Heavy performance issue with dedicated hybrid graphic card

Hello,
I have a Lenovo E590 notebook, which have an Intel UHD Graphics 620 and an AMD Radeon RX 550X. On this machine, I installed an Ubuntu 20.04 LTS. Both graphic card are detected and the driver looks fine, too.
Code:
sudo lshw -c display
  *-display                 
       Beschreibung: VGA compatible controller
       Produkt: UHD Graphics 620 (Whiskey Lake)
       Hersteller: Intel Corporation
       Physische ID: 2
       Bus-Informationen: pci@0000:00:02.0
       Version: 00
       Breite: 64 bits
       Takt: 33MHz
       Fähigkeiten: pciexpress msi pm vga_controller bus_master cap_list rom
       Konfiguration: driver=i915 latency=0
       Ressourcen: irq:139 memory:b1000000-b1ffffff memory:80000000-9fffffff ioport:4000(Größe=64) memory:c0000-dffff
  *-display
       Beschreibung: Display controller
       Produkt: Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
       Hersteller: Advanced Micro Devices, Inc. [AMD/ATI]
       Physische ID: 0
       Bus-Informationen: pci@0000:03:00.0
       Version: c0
       Breite: 64 bits
       Takt: 33MHz
       Fähigkeiten: pm pciexpress msi bus_master cap_list rom
       Konfiguration: driver=amdgpu latency=0
       Ressourcen: irq:140 memory:a0000000-afffffff memory:b0000000-b01fffff ioport:3000(Größe=256) memory:b2400000-b243ffff memory:b2440000-b245ffff
Code:
lspci -nnk | grep -A3 "\[03..\]:" 
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 (Whiskey Lake) [8086:3ea0]
	Subsystem: Lenovo UHD Graphics 620 (Whiskey Lake) [17aa:5073]
	Kernel driver in use: i915
	Kernel modules: i915
--
03:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X] [1002:699f] (rev c0)
	Subsystem: Lenovo Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X] [17aa:5073]
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
The Intel graphic card works fine and via env DRI_PRIME=1 I can use the AMD graphic card and I can get the OpenGL informations:
Code:
glxinfo | grep OpenGL
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) UHD Graphics 620 (WHL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.2.6
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.2.6
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.2.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
Code:
env DRI_PRIME=1 glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Radeon 500 Series (POLARIS12, DRM 3.38.0, 5.8.0-40-generic, LLVM 11.0.0)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.2.6
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.2.6
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.2.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
But with connected docking station, I have heavy performance issues.
To have some numbers, I had tested the performance with SuperTuxKart (with same settings).
With connected docking station (Lenovo ThinkPad USB 3.0 Pro Dock and DisplayLink Linux Software, version 5.3.1.34), the Intel graphic card gives 22-30 FPS in SuperTuxKart, and the AMD graphic card 11-15 FPS (less than the Intel graphic card!).
If I disconnected the docking station, SuperTuxKart run on Intel graphic card with 35-51 FPS and the AMD graphic card stable on 60 FPS.
I think this is an issue, especially because with connected docking station the AMD graphic card is much more weak as the Intel graphic card, against the behavior with disconnected docking station.
Attached Files
File Type: zip DLSupportTool_Output_2021-01-28T16:15:04.925154.zip (1.41 MB, 0 views)

Last edited by SWP Sebastian; 01-28-2021 at 03:51 PM.
SWP Sebastian is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.