Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-03-2018, 05:22 PM   #1
singa-banga
Junior Member
 
Join Date: Dec 2018
Posts: 4
Exclamation DisplayLink process 20-30% CPU on ThinkPad L570, Windows 7 64bit

Hi,

First off, great product it is indeed.

I have two 4K monitors connected to DL-6950 equipped adapter, ( https://i-tec.cz/en/produkt/u3dual4khdmi-2/ ).

On home Windows 10 laptop from 2014, no problem. Smooth.

On 2017 ThinkPad L570 (work laptop) Windows 7, DLUA using 20-30% CPU, causing noticeable lag and mouse skipping.

The productivity boost from 2x4K monitors still outweighs the disadvantage, but boy, if I had smooth operation, would I be transported into productivity heaven.

I am using latest DL driver from 28.11.2018, but the issue was the same with the previous version.

Laptop: ThinkPad L570, i5, 4 x USB 3.0 ports, Intel HD 620 graphics (latest driver), 8GB RAM.

Restarting the DL service doesn't help.

I don't know what USB 3.0 controller is on the machine, there are no drivers for USB available on Lenovo product page.

Is this a known problem? What can I do? Please help. :-(

Last edited by singa-banga; 12-03-2018 at 07:52 PM.
singa-banga is offline   Reply With Quote
Old 12-03-2018, 07:42 PM   #2
singa-banga
Junior Member
 
Join Date: Dec 2018
Posts: 4
Default

Ok so after much googling I found the latest USB 3.0 drivers for my laptop - 5.0.4.43 Intel USB 3.0 Driver - sadly no improvement at all.

I tried also unplugging all other USB devices. Nope hasn't fixed it.
singa-banga is offline   Reply With Quote
Old 12-05-2018, 09:12 AM   #3
singa-banga
Junior Member
 
Join Date: Dec 2018
Posts: 4
Default Solved!!!

Thanks to Wim from DisplayLink support who gave me the advice to enable Aero theme - CPU dropped to 0% and memory usage 150mb less.

So pleased (and baffled since Aero would seem to be more resource intensive).
singa-banga is offline   Reply With Quote
Old 11-13-2019, 04:10 PM   #4
Felwin
Junior Member
 
Join Date: Nov 2019
Posts: 2
Default

Got similar issues using windows 10, is there a similar solution ?
Felwin is offline   Reply With Quote
Reply

Tags
cpu, dlua, usb 3.0, windows 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.