Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-13-2021, 04:56 PM   #1
mauromol
Junior Member
 
Join Date: Mar 2015
Posts: 6
Unhappy Audio over HDMI: is it supposed to work?

I installed DisplayLink driver version 5.4 on Kubuntu 20.04. Video is working fine (apart from the usual problem of the high CPU usage of DisplayLinkManager process), but...

After driver installation, there's now a new audio device on my system, called "USB3.0 Dual Video Dock". For this device I can choose among a lot of different profiles, like analog stereo output, analog stereo duplex, IEC958 digital output, IEC958 digital duplex, some analog surround outputs, etc..
However, whatever I choose, the audio does not reach my monitor via the HDMI cable (yes, my monitor has built-in speakers...).

Please note, I'm not talking about the analog jack output on the docking station (which I never tested and not interested in), but rather about audio through the HDMI connection between the docking station and the monitor.

Is it supposed to work at all? Reading from other messages over the Internet, it seems like so...

The main annoyance is that Kubuntu is often turning this "USB3.0 Dual Video Dock" audio device as the system default one, hence I get no sound at all when it happens, unless I force one of the other audio devices to be back the default one.

Thanks in advance.
mauromol is offline   Reply With Quote
Reply

Tags
hdmi audio

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.