Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-22-2021, 10:59 PM   #1
bpiper
Junior Member
 
Join Date: Jul 2021
Posts: 1
Default DisplayLink device no longer detected on Kubuntu 20.04 with kernel 5.4.0-80

I have an HP USB-C Universal Dock that was previously working fine on kernel 5.4.0-77, but basically lost its DisplayLink functionality after I booted on 5.4.0-80 for the first time yesterday. Essentially it's no longer detecting the USB DisplayLink device (with vendor id 17e9) when the dock is plugged in. I tried a bunch of things, including reverting from the 5.4 DisplayLink driver back to 5.3, but the only solution that worked was booting the previous kernel version (5.4.0-77), so it seems that some kernel change has caused the issue.

Just posting this in case it helps others or a developer is able to comment.
bpiper is offline   Reply With Quote
Old 08-13-2021, 04:36 PM   #2
mauromol
Junior Member
 
Join Date: Mar 2015
Posts: 6
Default

It's strange, because I'm currently using the 5.4 driver in Kubuntu 20.04 with kernel 5.4.0-80 successfully.
Perhaps a failed dkms installation?
You may try to boot with the 5.4.0-80 kernel, then run: sudo dkms autoinstall
to see whether it fixes the problem...
mauromol is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.