Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-05-2020, 11:33 AM   #1
borjita
Junior Member
 
Join Date: Dec 2020
Posts: 1
Default Wavlink WL-UG39DK7 disconnect displays after 30 seconds

I have a WL-UG39DK7 dock and when I connect it to my PC (Windows 10 20H2), the display link driver disconnects after 30 seconds, and therefore I stop seeing my secondary screens. The system emits the typical windows sound of when a device is disconnected, and in the device manager you can see how the graphic adapter "USB3.0 5K Graphic Docking" disappears after 30 seconds. The rest of the ports of the dock (ethernet, usb, etc.) continue working correctly.

I have tried with a second PC but the result is the same. Any idea what it could be?

PS: attached video of the problem and logs of displaylink support tool

Thanks a lot.
Greetings,
Borja
Attached Files
File Type: zip Video-wavlink.zip (9.62 MB, 1 views)
File Type: zip DL_Windows_Logs_20201205_132221.zip (2.53 MB, 1 views)
borjita is offline   Reply With Quote
Old 12-09-2020, 12:02 PM   #2
JakubDabrowski
DisplayLink Tech Support
 
JakubDabrowski's Avatar
 
Join Date: Jan 2020
Location: Katowice, Poland
Posts: 256
Default

Hello borjita,

Thank you for reaching out to us here on the forum.

Based on your log files I see a potential issue in the USB connection as after the connection is set the docking stations gets a various USB errors that thwarts the connection.

May you please verify the below steps and let me know about the outcome?
  • Plug the dock into a different USB port - This will confirm that there is not an issue with the original USB port
  • Inspect the USB Up-Link port on the dock for damage - This could cause connectivity issues
  • Replace the USB cable connected to the dock and computer - This will confirm that there isn't an issue with the cable
  • Plug the dock into a USB 2.0 port or a USB 2.0 extension cable to force the dock to enumerate down to USB 2.0 mode - This will confirm if there is an issue on the USB 3.0 path
  • Does the device behave the same when plugged into another computer? - This will confirm if the issue lays with the original computer or dock.
  • Ensure all drivers are up to date.

Here is the newest DL driver, please update it also as you are using an older one: https://www.displaylink.com/downloads/file?id=1649

Kind regards,
Jakub
JakubDabrowski is offline   Reply With Quote
Reply

Tags
disconnect, wavlink

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.