Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-28-2018, 10:39 AM   #1
jinnko
Junior Member
 
Join Date: Sep 2018
Posts: 6
Default No DisplayPort signal with D6000 on XPS 9370 with Ubuntu 18.04, nor on macOS 10.13.6

Just received my D6000 today and have spent a fair bit of time trying to get the DisplayPort output working without success. Support logs attached.

- HDMI works from Ubuntu 18.04, though only at 30Hz. It does however lose signal occasionally :/
- On a Macbook Pro 13 mid 2015 model with macOS 10.13.6, HDMI sort of works, but not as a recognized display - only as a mirrored display that System Preferences isn't aware of. Similar issue on a Macbook Air, also with 10.13.6.
- Network, USB and power delivery to the XPS all seem to be working fine. Haven't tested the audio jack
- My DisplayPort cable and monitor work perfectly with my Dell DA300 mobile adapter.

I'm primarily interested in getting this working on my Ubuntu XPS laptop.

I have done the following:

- Installed the 4.2 driver from here.
- Disabled secure boot as described here.
- Configured modesetting with PageFlip disabled as described here.
- Tried increasing logging levels as described here, then connect and disconnect the DP cable from each of the two ports. No logging is emitted when the DP cable is inserted/removed.

Bottom line is I'd like to know whether the device is faulty and I should return it for a replacement.
Attached Files
File Type: zip sootsprite_2018-09-22T16:04:35.092651.zip (176.2 KB, 2 views)

Last edited by jinnko; 10-03-2018 at 03:36 PM.
jinnko is offline   Reply With Quote
Old 10-03-2018, 02:58 PM   #2
mlukaszek
Senior Member
 
mlukaszek's Avatar
 
Join Date: Feb 2010
Posts: 385
Default

Hi,

Have you attached the support logs somewhere? I cannot see them linked in your post

PS: For Mac problem, see support.displaylink.com and navigate to the section for Mac. In short, what you see (clone mode, with one extending screen driver through Airplay) is current behaviour on post-10.13.3 macOS versions - with an exception of 10.14 Mojave, where extended desktop support is restored.

Thanks
Michal
mlukaszek is offline   Reply With Quote
Old 10-03-2018, 03:37 PM   #3
jinnko
Junior Member
 
Join Date: Sep 2018
Posts: 6
Default

@mlukaszek - didn't realize my post was finally published. I've attached the support logs to the top post now.
jinnko is offline   Reply With Quote
Reply

Tags
d6000, da300, display port, ubuntu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.