Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-24-2024, 07:23 PM   #1
l00k
Junior Member
 
Join Date: Apr 2024
Posts: 2
Default Xorg + DL crashes on machine with new hardware

I was using DL for long time with my old laptop with i7-8750H + GTX 1060M
LMint 20.04
Kernel 5.15.0-100-generic
xserver-xorg-core 2:1.20.13-1ubuntu1
xserver-xorg / xorg 1:7.7+19
displaylink-driver 5.8.0-33

Now I migrated to new machine
14700K + GTX 4090
and I can't get DL running.

Tried various kernel versions, various mint versions (20, 21)
Tried the same config as on my old stack
Tried nouveau, nvidia closed, nvidia open drivers
Tried most suggested ideas from DL troubleshoot page, StackExchange etc.
Nothing works

Always the same problem - X server crashes just before displaying login screen.

In attachment output from DLSupportTool.

I'm willing to try all possible options and provide any additional logs. Build something from source etc.
This is clean setup so I can reinstall whole system if necessary.

EDIT:
I saw mention about special Xorg server version in pinned thread
https://www.displaylink.org/forum/sh...ad.php?t=67148
but download link is broken
Attached Files
File Type: zip DLSupportTool_Output_2024-04-24T21:05:13.153164.zip (379.2 KB, 0 views)

Last edited by l00k; 04-25-2024 at 05:43 PM.
l00k is offline   Reply With Quote
Old 04-26-2024, 12:33 AM   #2
l00k
Junior Member
 
Join Date: Apr 2024
Posts: 2
Default [Solved] Xorg + DL crashes on machine with new hardware

I've solved it.

The reason (I suppose) why it was not working was missing intel HD graphics driver for 14700k cpu in all available kernels I was able to test using Mint 20,21 Ubuntu 20.

`xrandr` was displaying only "default" without any options (missing driver)
`lshw -C display` output was suggesting non of devices was used (UNCLAIMED)

Sadly I was not able to use latest available kernels in mentioned above systems. System was just handing before login screen.

Finally I've tried Ubuntu 24.
All works out of the box!
Drivers claimed, all options available.
After installing DL driver from synaptic displays via dock also work.

Because I preper cinnamon desktop (Mint default) I just added it to Ubuntu and now I have all like I want.

Hope this will help someone.
l00k is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.