Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-23-2021, 02:19 PM   #1
HolographicDoc
Junior Member
 
Join Date: Jan 2021
Posts: 2
Default "No Monitor Detected" Mac M1 Big Sur 11.1

I'm trying to connect two displays, but when I run Displaylink, it always says the connection status is "No monitor detected"

I'm using a 2020 MacBook Pro on M1 chip, Big Sur 11.1, and a startech USB-C to 2x displayport adapter. I've installed DisplayLink Manager Graphics Connectivity 1.2. Screen recording is enabled for Displaylink. This is my first time using this software (i.e. it's not like it worked previously for me)

I am able to plug one of my DP cables into the Startech adapter and successfully extend my screen to one monitor. When I plug the second cable in, only one monitor works and it appears blurred (as though two images are overlaid on one another). Regardless of the connection, Displaylink always says "no monitor detected".

I've tried many re-installs, restarts, without success. Perhaps relevant, in Software > Extensions there is no DisplayLinkDriver.kext at all when I install the most recent version (when I tried to install a legacy version, this extension became present but was not loaded - even though I gave appropriate permissions when I tried that).
HolographicDoc is offline   Reply With Quote
Old 01-25-2021, 12:12 PM   #2
rboerner
Super Moderator
 
Join Date: Jan 2015
Posts: 67
Default

Quote:
Originally Posted by HolographicDoc View Post
I'm trying to connect two displays, but when I run Displaylink, it always says the connection status is "No monitor detected"

I'm using a 2020 MacBook Pro on M1 chip, Big Sur 11.1, and a startech USB-C to 2x displayport adapter. I've installed DisplayLink Manager Graphics Connectivity 1.2. Screen recording is enabled for Displaylink. This is my first time using this software (i.e. it's not like it worked previously for me)

I am able to plug one of my DP cables into the Startech adapter and successfully extend my screen to one monitor. When I plug the second cable in, only one monitor works and it appears blurred (as though two images are overlaid on one another). Regardless of the connection, Displaylink always says "no monitor detected".

I've tried many re-installs, restarts, without success. Perhaps relevant, in Software > Extensions there is no DisplayLinkDriver.kext at all when I install the most recent version (when I tried to install a legacy version, this extension became present but was not loaded - even though I gave appropriate permissions when I tried that).
I can't be sure since you don't mention the specific model number of the StarTech adapter you are using, however based on your description it doesn't sound like the adapter you have is using DisplayLink technology.

If pressed to guess, the StarTech adapter you are using is based on DisplayPort MST hub technology, which is not supported on Macs.
rboerner is offline   Reply With Quote
Old 01-25-2021, 07:13 PM   #3
Jeff4
Junior Member
 
Join Date: Jan 2021
Posts: 1
Default no support then?

Using StarTech TB3CDK2DP docking station, 2 Active DisplayPort to HDMI adapters, DisplayPort Manager V 1.2 and still no monitor detected.

Why does the M1 chip display on one external monitor but the DisplayLink Manager says there are no monitors detected?

How do you plan to fix DisplayLink Manager so it recognizes the connected monitor I read the message:: "Connection Status: No monitor detected" on?

Last edited by Jeff4; 01-25-2021 at 07:16 PM. Reason: Added hardware
Jeff4 is offline   Reply With Quote
Old 01-26-2021, 11:53 AM   #4
jasan
Junior Member
 
Join Date: Jan 2021
Posts: 3
Default Same problem + dock freezing

Same problem here. App does not register my monitor (MB16ACE). It miraculously works, when I use usb-c port in my HP monitor, byt not in my macbook pro.

Also, when I try tu show dock on asus MB16ACE, dock and whole mission control freezes until i kill dock.
jasan is offline   Reply With Quote
Old 01-26-2021, 12:06 PM   #5
rboerner
Super Moderator
 
Join Date: Jan 2015
Posts: 67
Default

Quote:
Originally Posted by Jeff4 View Post
Using StarTech TB3CDK2DP docking station, 2 Active DisplayPort to HDMI adapters, DisplayPort Manager V 1.2 and still no monitor detected.

Why does the M1 chip display on one external monitor but the DisplayLink Manager says there are no monitors detected?

How do you plan to fix DisplayLink Manager so it recognizes the connected monitor I read the message:: "Connection Status: No monitor detected" on?
According to the specifications published by StarTech for your dock --> https://www.startech.com/en-us/cards-adapters/tb3cdk2dp it does NOT use DisplayLink technology. It is using Thunderbolt 3/USB-C technology.

This is why the DisplayLink Manager App says no monitor detected, because there is in fact no monitor connected to the system using DisplayLink technology.

Apple M1-based laptops only support one external display via Thunderbolt 3/USB-C. This is why only one external display will work. This is a limitation of the laptop, not a limitation of the StarTech dock.

If you have further questions, I would suggest contacting StarTech directly for assistance (since the product you are using does not use DisplayLink technology).
rboerner is offline   Reply With Quote
Old 01-28-2021, 11:01 PM   #6
HolographicDoc
Junior Member
 
Join Date: Jan 2021
Posts: 2
Default

Quote:
Originally Posted by rboerner View Post
I can't be sure since you don't mention the specific model number of the StarTech adapter you are using, however based on your description it doesn't sound like the adapter you have is using DisplayLink technology.

If pressed to guess, the StarTech adapter you are using is based on DisplayPort MST hub technology, which is not supported on Macs.


Ugg - yep, stupid mistake, but I didn't realize that display link only worked with certain adapters. I've now switched to a different adapter and that seems to have fixed the issue. Thanks for your help!
HolographicDoc is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.