Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-17-2021, 01:33 AM   #1
cphillip
Junior Member
 
Join Date: Sep 2021
Posts: 1
Thumbs down Big Sur 11.6 with DisplayLink 1.5.0 (Build 58.125) Dual Monitor Flicker Issues

Hi -

I recently purchased the UD-6950 (Plugable USB 3.0 Dual DisplayPort 4K Monitor Universal Laptop Docking Station for Windows and Mac (Dual 4K DisplayPort, Gigabit Ethernet, Audio, 6 USB Ports).

I have dual LG monitors 24in and 32in Non 4K with an Apple M1 MacBook Pro.
I have installed the latest DisplayLink software, and both monitors turn on. However, immediately, the monitor that I had plugin into the top display port input started to go blank in and out (Still does), and my other monitor screen has a filker very noticeable on a white background.

I'm not sure what to do in this case. I changed both display port cables, and nothing changed. Should I return this unit? Is it possible that it might be defective, or should I wait for an updated version of the driver?
cphillip is offline   Reply With Quote
Old 09-17-2021, 11:01 AM   #2
rboerner
Super Moderator
 
Join Date: Jan 2015
Posts: 116
Default

Quote:
Originally Posted by cphillip View Post
Hi -

I recently purchased the UD-6950 (Plugable USB 3.0 Dual DisplayPort 4K Monitor Universal Laptop Docking Station for Windows and Mac (Dual 4K DisplayPort, Gigabit Ethernet, Audio, 6 USB Ports).

I have dual LG monitors 24in and 32in Non 4K with an Apple M1 MacBook Pro.
I have installed the latest DisplayLink software, and both monitors turn on. However, immediately, the monitor that I had plugin into the top display port input started to go blank in and out (Still does), and my other monitor screen has a filker very noticeable on a white background.

I'm not sure what to do in this case. I changed both display port cables, and nothing changed. Should I return this unit? Is it possible that it might be defective, or should I wait for an updated version of the driver?
DisplayLink makes the core technology that is integrated by other companies into their own products.

If you have not already done so, I would suggest contacting Plugable directly for assistance --> https://plugable.com/pages/support
rboerner is offline   Reply With Quote
Old 09-17-2021, 12:22 PM   #3
TwoMonitors
Junior Member
 
Join Date: Sep 2021
Posts: 1
Default

I am having the same issue. It started like 1 week ago. Also change the both cables. I have my DisplayLink module since a year ago and just until now I am having this problem. Any other ideas guys?
TwoMonitors is offline   Reply With Quote
Old 09-19-2021, 04:00 PM   #4
oneMonitor
Junior Member
 
Join Date: Sep 2021
Posts: 2
Default

have the same bug with Macbook Pro M1

with the beta there was no flicker.
But the beta link where deleted on the homepage
Next time i save old versions...
oneMonitor is offline   Reply With Quote
Old 09-25-2021, 02:26 AM   #5
oneMonitor
Junior Member
 
Join Date: Sep 2021
Posts: 2
Default

uninstalled version 1.5,
version 1.4 installed,
after a few days and after some new rebooting, installed 1.5 again and works without flickering.
oneMonitor is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.