Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-06-2021, 11:42 AM   #1
cwhite87
Junior Member
 
Join Date: Sep 2021
Posts: 2
Default Ubuntu 20.04 - Displays Not Working After Unplugging Dock

Hello,

I am on Ubuntu 20.04, kernel 5.11.0-27 and using version 5.4 of the Display Link driver and EVDI 1.9.1. The first time I plug in the dock both of my monitors appear and everything works fine. A problem arises if I unplug (for example to use another computer with the dock) and then try to plug back in to the Ubuntu machine - nothing, blank screens. A restart fixes this.

I also unable to properly shut down the PC if using DisplayLink, the monitors go blank, but the fans and LEDs remain on, having to be turned off by holding the power button.

It always worked fine in the past, I could unplug the dock and plug it back in later, so I suspect it's a conflict with the kernel and driver versions, but does anyone have any ideas to sort it?
cwhite87 is offline   Reply With Quote
Old 09-06-2021, 02:51 PM   #2
cwhite87
Junior Member
 
Join Date: Sep 2021
Posts: 2
Default

Update:

I installed kernel 5.8.18 from mainline and everything works as expected with driver 5.4 now. I was recently upgraded to 5.11 from 5.8 by the hardware enablement features. My hardware worked fine on 5.8, so I've just reinstalled it and made sure GRUB loads that kernel at start up and all works as expected.
cwhite87 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.