Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-05-2023, 04:10 PM   #11
Jbruntzel
Junior Member
 
Join Date: Jan 2023
Posts: 2
Thumbs down Come on DisplayLink..... This is silly.....

So I just got a brand new Mac Book Pro M1. One of the first things I did was update iOS to Ventura. (Dumb thing to do I guess?). Then purchased Plugable's 14-1 Dock Station and nothing works at all.

So stupid.........

I have 2 HDMI 27 inch monitors I'm trying to extend. 2 "musical" keyboard controllers via 3.0 USB, and a Focusrite Audio interface Scarlett 18i20 for 2 digital audio workstations. Propellerhead Reason and Logic Pro.

Sounds like we are dead in the water until DisplayLink gets their act together.

I can plug 1 monitor HDMI direct to the Mac book and it instantly works. However I next 2 monitors thus the docking station.

All this feels like IT problems from back in the day circa 2002-ish.....
Jbruntzel is offline   Reply With Quote
Old 01-05-2023, 09:15 PM   #12
Jbruntzel
Junior Member
 
Join Date: Jan 2023
Posts: 2
Default

Wrong solutions for me..... I'm out DisplayLinks. Nothing personal. I've learned I need a solutions is that more audio centric.
Jbruntzel is offline   Reply With Quote
Old 01-12-2023, 10:28 AM   #13
nmlawson
Junior Member
 
Join Date: Jan 2023
Posts: 2
Default M1 MacBook Pro (2020) - Ventura version 13.1

I'm using a 2020 M1 MacBook Pro running on Ventura 13.1 and am experiencing the same issues reported here in the thread. Would be great if the engineers @DisplayLink would release an update that overcomes this issue!

I bought a DisplayLink device specifically to overcome the lack of native dual screen capabilities of the M1 MacBooks! I can't help but feel this should be one of their strongest segments in terms of power users?

Please release an update ASAP - Or at least share details around what timeline we're looking at...
nmlawson is offline   Reply With Quote
Old 01-12-2023, 02:51 PM   #14
nmlawson
Junior Member
 
Join Date: Jan 2023
Posts: 2
Default M1 MacBook Pro (2020) - Ventura 13.1 Update [Display Detection Issue Resolved]

M1 MacBook Pro (2020)
Updated from Ventura 13.0.1 to 13.1, uninstalled and re-installed DisplayLink drivers (including log in screen extension), restarted Wavlink Docking station and everything is back up and running on my dual-display setup.

N.B.!!! Follow the exact setup procedure for granting permissions for MacOS (screen recording AND notifications) as outlined in this support post:
https://support.displaylink.com/know...ticles/1932214
nmlawson is offline   Reply With Quote
Old 01-15-2023, 05:44 PM   #15
lerdaed
Junior Member
 
Join Date: Jan 2023
Posts: 2
Default

I have the same problem but nothing helped me so far. I read somewhere else that the firmware update to version "A03" could help. However this firmware has been removed from the official DELL website and I can't find it.
If anyone has this exact version of firmware for D6000, can you send it to me in PM?
The filename is: Dock_D6000_FW_Updater_A03_T8Y8T.exe

Thanks
lerdaed is offline   Reply With Quote
Old 02-03-2023, 04:13 PM   #16
rbondar
Junior Member
 
Join Date: Feb 2023
Location: Massachusetts
Posts: 1
Default Ventura working with DisplayLink

I'm using the Kensington model SD4780P dual 4k docking station and lost connection to the monitors when I updated my Mac OS to Ventura.
I had to uninstall the driver and went to synaptics.com and reinstalled the MacOS driver which had Ventura 13 listed as ok.
This worked for me.
rbondar is offline   Reply With Quote
Old 03-21-2023, 04:59 PM   #17
sparcus
Junior Member
 
Join Date: Mar 2023
Posts: 1
Default Dual monitor works now, but maybe not a fix...

Hi Guys,

I upgraded to Mac OSX 13.2.1 Ventura last night, and my plugable UD-3900PDZ dock stopped working with one of the two external monitors.

I had to unplug HDMI 1 monitor, and plug HDMI monitor 2 into the number 1 port first, then plug the original HDMI1 monitor into port 2 in this sequence to work. I don't know why but this is how I managed to get it working. If I tried this new setup without this sequence it would only work with one monitor.

Hopefully, this helps someone that has issues displaying both external monitors.
sparcus is offline   Reply With Quote
Old 06-27-2023, 08:36 AM   #18
manikcz
Junior Member
 
Join Date: Jun 2023
Posts: 1
Default

I have the same issue, read all posts in thread here:
https://discussions.apple.com/thread...2968022&page=5

Nothing helped though. I cannot see any DisplayLink device in the USB devices which I should I assume?

I reinstalled the DisplayLink manager, nothing helped. Any check from the DisplayLink developers would be highly appreciated.
manikcz is offline   Reply With Quote
Old 07-05-2023, 07:12 PM   #19
gc134
Junior Member
 
Join Date: Jul 2023
Posts: 5
Default

Quote:
Originally Posted by manikcz View Post
I have the same issue, read all posts in thread here:
https://discussions.apple.com/thread...2968022&page=5

Nothing helped though. I cannot see any DisplayLink device in the USB devices which I should I assume?

I reinstalled the DisplayLink manager, nothing helped. Any check from the DisplayLink developers would be highly appreciated.
Guessing this is an apple issue. Almost wonder if they did it on purpose to stop people from using 3+ monitors without paying for the better CPU...
gc134 is offline   Reply With Quote
Old 07-05-2023, 07:30 PM   #20
gc134
Junior Member
 
Join Date: Jul 2023
Posts: 5
Default

Quote:
Originally Posted by manikcz View Post
I have the same issue, read all posts in thread here:
https://discussions.apple.com/thread...2968022&page=5

Nothing helped though. I cannot see any DisplayLink device in the USB devices which I should I assume?

I reinstalled the DisplayLink manager, nothing helped. Any check from the DisplayLink developers would be highly appreciated.
Guessing this is an apple issue. Almost wonder if they did it on purpose to stop people from using 3+ monitors without paying for the better CPU...
gc134 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.