Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-26-2021, 04:12 PM   #1
dominik.zogg
Junior Member
 
Join Date: Jan 2021
Posts: 1
Default Very low performance with AMD Ryzen Pro 4750U

I bought a Club Dual 4k Dock (Displaylink):

I got to notebooks, one for work, one for private, both running Ubuntu 20.10
The first got a Intel® Core™ i7-10710U Processor and the dock works well.
The second got a AMD Ryzen Pro 4750U and the performance of the external sceens is very low.

Moving windows redraw that slow that it looks like wobbling, parts of the window are moved others aren't. Mouse cursor feels a bit more fluid, but far from usable.
dominik.zogg is offline   Reply With Quote
Old 01-29-2021, 03:02 PM   #2
Blafasel
Junior Member
 
Join Date: Jan 2021
Posts: 1
Default Same Issue

I got exactly the same issue. Processor is a AMD Ryzen 4800H with integrated graphics (no dedicated graphic card).

When I connect a monitor directly to my Laptops HDMI Output, everything is great.

Via the docking station its basically unusable, even Youtube Videos have a lot of fragmentation going on while playing. It seems like the signal is separated into several horizontal blocks and they get updated one after the other with a noticable delay between each block.
Blafasel is offline   Reply With Quote
Old 04-16-2021, 11:32 AM   #3
ff801
Junior Member
 
Join Date: Apr 2021
Posts: 2
Default

same here. performance is really bad. basically this stuff is unusable.
ff801 is offline   Reply With Quote
Old 04-19-2021, 07:22 AM   #4
irvis
Junior Member
 
Join Date: Apr 2021
Posts: 1
Question Same here

Hey,
Sorry to write it, but same here.
Tried on Ubuntu 20.04 and 20.10.
Drivers version tried 5.3.1.34 and 5.4.0-55.153.
Laptop:
  • Processor: AMD® Ryzen 5 pro 4650u with radeon graphics × 12
  • Graphics: AMD® Renoir
System:
  • Gnome Version: 3.38.3
  • Kernel: Linux 5.8.0-50-generic x86_64
  • OS: Ubuntu 20.10

All works good, until I plug in docking station. Then system seems to behave like drunk old man. I get out of nowhere latency between click and run program, each window is fragmenting once moving, unusable, not able to work on that
as I recall on Ubuntu 18.04 and 18.10 it was ok. So I suspect drivers.

Do you think this can be connected with issue described here
irvis is offline   Reply With Quote
Old 04-21-2021, 01:19 PM   #5
spikerguy
Junior Member
 
Join Date: Apr 2021
Posts: 2
Default

Hello,

We're all in the same boat.
I have shared my device details Here

Why my situation is explained Here

I hope DisplayLink can atleast make use of GPU for Linux users.

Looking forward for a fix.

Manjaro Team.
spikerguy is offline   Reply With Quote
Old 04-26-2021, 02:05 PM   #6
MTrien
Junior Member
 
Join Date: Apr 2021
Posts: 1
Default Same here

I have to same problem under Ryzen 5 3500u. The fix with the amdgpu drivers doesnt work here because the Radeon Vega Mobile Gfx is not supported. I had a problem with grafic glitches. Please fix these problems.
MTrien is offline   Reply With Quote
Reply

Tags
amd, amdgpu, performance

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.