Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-04-2020, 12:16 PM   #41
PilotPaul
Junior Member
 
Join Date: Mar 2020
Posts: 15
Default

Quote:
Originally Posted by Jeins View Post
Yep. Both are installed. I uninstall both an let the installer install them, but that don't work too.
Quote:
Originally Posted by Jeins View Post
lsb_release -a:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04 LTS
Release: 20.04
Codename: focal

uname -a:

Linux Jonas-Linux 5.4.0-28-generic #32-Ubuntu SMP Wed Apr 22 17:40:10 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

apt search:

Sortierung... Fertig
Volltextsuche... Fertig
libdrm-dev/focal,now 2.4.101-2 amd64 [installiert]
Benutzerbereichsschnittstelle zu Kernel-DRM-Diensten Entwicklungsdateien
Well I'm assuming that the German is the same as my English version! :-) The only difference i have is that I am running kernel 5.4.0-29.generic...maybe try enabling the focal-proposed repository?
PilotPaul is offline   Reply With Quote
Old 05-04-2020, 12:19 PM   #42
Jeins
Junior Member
 
Join Date: May 2019
Posts: 12
Default

Quote:
Originally Posted by PilotPaul View Post
Well I'm assuming that the German is the same as my English version! :-) The only difference i have is that I am running kernel 5.4.0-29.generic...maybe try enabling the focal-proposed repository?
I hope so! Okay I will give it a try. Thanks
Jeins is offline   Reply With Quote
Old 05-04-2020, 12:21 PM   #43
PilotPaul
Junior Member
 
Join Date: Mar 2020
Posts: 15
Default

You could also try "sudo apt -f install" to fix any missing dependencies before re-running the installation...
PilotPaul is offline   Reply With Quote
Old 05-04-2020, 12:34 PM   #44
Jeins
Junior Member
 
Join Date: May 2019
Posts: 12
Default

Tried that before. Don't help. And also with new kernel, I get the same error
Jeins is offline   Reply With Quote
Old 05-04-2020, 01:35 PM   #45
PilotPaul
Junior Member
 
Join Date: Mar 2020
Posts: 15
Default

Quote:
Originally Posted by Jeins View Post
Tried that before. Don't help. And also with new kernel, I get the same error
Interesting...

I've done a "apt search libdrm" on my system for comparison. Output is as follows:

"Sorting...
Full Text Search...
libdrm-amdgpu1/focal,now 2.4.101-2 amd64 [installed]
Userspace interface to amdgpu-specific kernel DRM services -- runtime

libdrm-common/focal,focal,now 2.4.101-2 all [installed]
Userspace interface to kernel DRM services -- common files

libdrm-dev/focal,now 2.4.101-2 amd64 [installed]
Userspace interface to kernel DRM services -- development files

libdrm-intel1/focal,now 2.4.101-2 amd64 [installed]
Userspace interface to intel-specific kernel DRM services -- runtime

libdrm-nouveau2/focal,now 2.4.101-2 amd64 [installed]
Userspace interface to nouveau-specific kernel DRM services -- runtime

libdrm-radeon1/focal,now 2.4.101-2 amd64 [installed]
Userspace interface to radeon-specific kernel DRM services -- runtime

libdrm-tests/focal 2.4.101-2 amd64
Testing tools from the libdrm project

libdrm2/focal,now 2.4.101-2 amd64 [installed]
Userspace interface to kernel DRM services -- runtime

libdrmaa1.0-java/focal,focal 8.1.9+dfsg-9build2 all
Distributed resource management Application API library - Java bindings

libdrmaa1.0-java-doc/focal,focal 8.1.9+dfsg-9build2 all
Distributed resource management Application API library - Java bindings docs

libdrmaa1.0-ruby/focal,focal 8.1.9+dfsg-9build2 all
Distributed resource management Application API library - Ruby bindings"

Maybe you are missing one of these? Just a thought...
PilotPaul is offline   Reply With Quote
Old 05-04-2020, 02:05 PM   #46
davidjonbarnes@yahoo.co.u
Junior Member
 
Join Date: Apr 2020
Posts: 3
Smile Working with new 20.04 DisplayLink driver

Only thing extra I had to do even though on Intel graphics I
had to make /usr/share/X11/xorg.conf.d/20-displaylink.conf
contain:
Section "Device"
Identifier "DisplayLink"
Driver "modesetting"
Option "PageFlip" "false"
EndSection

not this:
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
EndSection
davidjonbarnes@yahoo.co.u is offline   Reply With Quote
Old 05-04-2020, 02:07 PM   #47
PilotPaul
Junior Member
 
Join Date: Mar 2020
Posts: 15
Default

Quote:
Originally Posted by davidjonbarnes@yahoo.co.u View Post
Only thing extra I had to do even though on Intel graphics I
had to make /usr/share/X11/xorg.conf.d/20-displaylink.conf
contain:
Section "Device"
Identifier "DisplayLink"
Driver "modesetting"
Option "PageFlip" "false"
EndSection

not this:
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
EndSection
I needed this with the 5.2 driver, but not for the 5.3 one, which works with both X and Wayland...I'm using Intel HD 4600 graphics (builtin).
PilotPaul is offline   Reply With Quote
Old 05-04-2020, 02:17 PM   #48
Jeins
Junior Member
 
Join Date: May 2019
Posts: 12
Default

Now I have the same output, but that don't change anything.
Jeins is offline   Reply With Quote
Old 05-04-2020, 02:20 PM   #49
PilotPaul
Junior Member
 
Join Date: Mar 2020
Posts: 15
Default

Quote:
Originally Posted by Jeins View Post
Now I have the same output, but that don't change anything.
Have you removed any previous installations, such as the displaylink-debian one, before trying the new installation? I removed all previous displaylink drivers and re-booted before trying the latest one...
PilotPaul is offline   Reply With Quote
Old 05-04-2020, 02:24 PM   #50
Jeins
Junior Member
 
Join Date: May 2019
Posts: 12
Default

Yes. I used the displaylink uinstaller
Jeins is offline   Reply With Quote
Reply

Tags
ubuntu 20

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.