Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-17-2020, 08:49 PM   #1
squidgemonster
Junior Member
 
Join Date: Nov 2020
Posts: 4
Default Update for M1 Macbooks

Hi forum folks

Has there been any announcement on support for multiple monitors for the newly announced M1 MacBooks? My understanding is that they are limited to one external, extended display... would this still apply to monitors attached to a Displaylink dock...?

I'd love to be able to run the laptop screen, a HD and 2K screen - that work fine with my mid-2014 Macbook Pro via USB 3...
squidgemonster is offline   Reply With Quote
Old 11-18-2020, 01:22 AM   #2
squidgemonster
Junior Member
 
Join Date: Nov 2020
Posts: 4
Default

Well this is reassuring: https://youtu.be/gnBIorfD5YU
squidgemonster is offline   Reply With Quote
Old 11-28-2020, 10:52 PM   #3
davss
Junior Member
 
Join Date: Nov 2020
Posts: 7
Default

In short - DL drivers work on Apple MacBook Air 13 inch A2337 only in horizontal mode and there is no visible lags! DO NOT INSTALL an add-on 'macOS App Login Extension.dmg' suggested in DisplayLink Manager s this will mess up DL software which won't load anymore thus no more external USB monitors :/

I just got my Air A2337, installed the latest DL drivers (Release: 1.1 13 Aug 2020) and allowed access in security for the driver to work. At first was nicely surprised as my 2 USB Dell 2515H came online with no lag! I have these monitors connected via UGREEN single USB-C hub model CM179. I also have a third Dell 2515H monitor connected via HDMI in this hub and it's working fine. I was quite excited and went to change rotation on the other two DL USB monitors as use them in vertical mode. When changed from 'Standard' rotation to any 90, 180 or 270 it freezes picture on screens for some time then flashes once and it's back to 'Standard' horizontal so rotation doesn't work no matter what I do and fiddle with resolutions/refresh rates.

Now, I poked around in DisplayLink Manager (in top menu bar) and noticed an add-on under file name 'macOS App Login Extension.dmg' hasn't been installed.
Therefore, downloaded it and installed. This really messed up my Big Sur 11.0 and it went into black screen after a reboot and login. When I hit keys it would only flash login screen and then back to black again. I was only able to get back into the OS X after completely unplugging the USB-C hub with external monitors. I then uninstalled the DL driver and this ugly add-on but unfortunately it BROKE my DisplayLink driver now completely as it's not longer starts/working even after complete removal and reinstallation .
davss is offline   Reply With Quote
Old 11-29-2020, 01:32 PM   #4
kmillard
Junior Member
 
Join Date: Jun 2012
Posts: 11
Default flickering and out of order

I have had the same issues with flickering with my M1 Mac. I have talked to apple and have a conversation with them set for tomorrow with a senior advisor.
I thought it was the DL problem but it turns out to be a Big Sur/ M1 / HDMI issue.
You can read about it here.
https://discussions.apple.com/thread...022&login=true

Also I don't know if this is related but my displays are out of order upon wake from deep sleep.
Anyone else having that problem?
kmillard is offline   Reply With Quote
Old 12-01-2020, 09:05 AM   #5
davss
Junior Member
 
Join Date: Nov 2020
Posts: 7
Default

Quote:
Originally Posted by kmillard View Post
I have had the same issues with flickering with my M1 Mac. I have talked to apple and have a conversation with them set for tomorrow with a senior advisor.
I thought it was the DL problem but it turns out to be a Big Sur/ M1 / HDMI issue.
You can read about it here.
https://discussions.apple.com/thread...022&login=true

Also I don't know if this is related but my displays are out of order upon wake from deep sleep.
Anyone else having that problem?
Re displays out of order - I had the same issue with a MBP 16" on Catalina with my monitors connected directly to it via USB-C -> DP using 2 different brands quality cables or Satechi dual HDMI adapter/hub. It's OS X that didn't remember locations set on displays.
DL, not the other hand, was doing a great job and my displays were exactly where I had them before disconnecting.

Last edited by davss; 12-01-2020 at 09:18 AM.
davss is offline   Reply With Quote
Old 12-02-2020, 05:27 PM   #6
DerekC
Junior Member
 
Join Date: Dec 2020
Posts: 2
Question Monitor not found

I have Dell 6000 dock (with dual DP monitors) connected to my mac via USB-c, and DL Manager says no monitor found... Is there any trick to getting DL to see my dock?

https://www.dell.com/en-uk/work/shop...pc-accessories
DerekC is offline   Reply With Quote
Old 12-02-2020, 06:01 PM   #7
DerekC
Junior Member
 
Join Date: Dec 2020
Posts: 2
Default USB SS did the trick!

I changed the dock to Dell D3100 which only has connection to USB3-ss and now it works! (It would seem the usb-c cable from the D6000 into the mac thunderbolt port is not compatible)

The down-side is that D3100 does not charge the laptop, so I need a separate power into the mac (for now). I ordered a direct USB-c to USB 3.1 cable to see if that will also charge the laptop... then I hope to switch back to the D6000 dock.

Quote:
Originally Posted by DerekC View Post
I have Dell 6000 dock (with dual DP monitors) connected to my mac via USB-c, and DL Manager says no monitor found... Is there any trick to getting DL to see my dock?

https://www.dell.com/en-uk/work/shop...pc-accessories
DerekC is offline   Reply With Quote
Old 12-22-2020, 07:10 AM   #8
xccess
Junior Member
 
Join Date: Dec 2020
Posts: 1
Default

Quote:
Originally Posted by davss View Post
In short - DL drivers work on Apple MacBook Air 13 inch A2337 only in horizontal mode and there is no visible lags! DO NOT INSTALL an add-on 'macOS App Login Extension.dmg' suggested in DisplayLink Manager s this will mess up DL software which won't load anymore thus no more external USB monitors :/

I just got my Air A2337, installed the latest DL drivers (Release: 1.1 13 Aug 2020) and allowed access in security for the driver to work. At first was nicely surprised as my 2 USB Dell 2515H came online with no lag! I have these monitors connected via UGREEN single USB-C hub model CM179. I also have a third Dell 2515H monitor connected via HDMI in this hub and it's working fine. I was quite excited and went to change rotation on the other two DL USB monitors as use them in vertical mode. When changed from 'Standard' rotation to any 90, 180 or 270 it freezes picture on screens for some time then flashes once and it's back to 'Standard' horizontal so rotation doesn't work no matter what I do and fiddle with resolutions/refresh rates.

Now, I poked around in DisplayLink Manager (in top menu bar) and noticed an add-on under file name 'macOS App Login Extension.dmg' hasn't been installed.
Therefore, downloaded it and installed. This really messed up my Big Sur 11.0 and it went into black screen after a reboot and login. When I hit keys it would only flash login screen and then back to black again. I was only able to get back into the OS X after completely unplugging the USB-C hub with external monitors. I then uninstalled the DL driver and this ugly add-on but unfortunately it BROKE my DisplayLink driver now completely as it's not longer starts/working even after complete removal and reinstallation .
funny I install extension and it work fine, I have two monitor at DisplayLink , one via thunderbolt 3 and buil in laptop screen

https://www.youtube.com/watch?v=yUmp...channel=xccess
xccess is offline   Reply With Quote
Old 01-07-2021, 10:12 AM   #9
paul s
Junior Member
 
Join Date: Jan 2021
Posts: 1
Default

I have a new macbook air M1. One external monitor works. I am trying to set up a second external monitor. I loaded Displaymanager, but it does not detect the second monitor. I am using an Alogic usb-c dockwave 3 in 1 (product code ULDWAV-SDR) to connect the monitors to the macbook air. Power delivery is “up to 60w”. Should this configuration be working?

Thanks for any help you can provide.

Paul S
paul s is offline   Reply With Quote
Old 01-13-2021, 01:10 PM   #10
TL75
Junior Member
 
Join Date: Jan 2021
Posts: 1
Default

Quote:
Originally Posted by paul s View Post
I have a new macbook air M1. One external monitor works. I am trying to set up a second external monitor. I loaded Displaymanager, but it does not detect the second monitor. I am using an Alogic usb-c dockwave 3 in 1 (product code ULDWAV-SDR) to connect the monitors to the macbook air. Power delivery is up to 60w. Should this configuration be working?

Thanks for any help you can provide.

Paul S

I have the same problem, two brand-new samsung monitors, Dell D6000 and MacBook Pro with an M1 processor. Black screen on one of the monitors. Hope that there is a work around.
TL75 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.