Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 08-05-2015, 11:25 AM   #1
mlukaszek
Senior Member
 
mlukaszek's Avatar
 
Join Date: Feb 2010
Posts: 386
Post First Ubuntu beta driver and 4.x+ kernels

Hi,

Since we have concentrated on supporting Ubuntu 14.04 LTS which does not include 4.x by default, the logic detecting the version in installer script will currently not deal with 4.x+ kernels correctly, and will present a misleading error message claiming the kernel version is too old.

A workaround is to extract the installer with
Code:
--keep --noexec
switches and edit displaylink-installer.sh script in an editor of choice.
Remove or change the kernel version check - look for a block starting with a comment "Required kernel version".

Then, after saving the file, you can start the modified installer manually by running:
Code:
chmod +x displaylink-installer.sh
sudo ./displaylink-installer.sh install
Please note that we have not tested compatibility with newer kernel versions, and changes in DRM they include. It is possible that evdi kernel module would need modifications to work properly. Contributions to evdi are welcome.

Thanks,
Michal
mlukaszek is offline  
Closed Thread

Tags
kernel, linux, ubuntu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.