Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-25-2021, 05:46 PM   #1
AndrewM
Junior Member
 
Join Date: Oct 2021
Posts: 1
Default Latest DisplayLink driver grinding performance to a halt

I have the following system:
Dell XPS15 9570
Intel Core i9-8950
32 GB RAM
1 TB SSD
Intel UHD Graphics 630
Nvidia GeForce GTX 1050 Ti
Dell WD15 Dock

DisplayLink item at issue: DisplayLink Graphics. Product Version: 10.1.2875.0. Product Language: 2057. Manufacturer: DisplayLink Corp.

I utilize the dock for camera, 3D mouse and ethernet. I do not use the dock for display connection as there does not appear to be any means to leverage the NVIDIA card this way. The display is connected via the laptop's HDMI port.

After the system was updated with the DisplayLink driver above, the system appeared to use only the Intel graphics chipset, which would quickly bog down when using SolidWorks. When the screen would freeze, the performance tab of the task manager would show the Intel graphics device as being maxed out, while the NVIDIA card was entirely idle. This behaviour persisted until the driver was removed, and system performance returned to normal.

However, an on-going issue with remote connection to an SQL database that was resolved by the driver update has returned. This is most frustrating, and the means to troubleshoot it seem very opaque.
AndrewM is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.