Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-22-2019, 03:22 PM   #1
erik070
Junior Member
 
Join Date: Jul 2019
Posts: 2
Default D6000 disconnects at random

I've been trying to use a D6000 port replicator with a Dell XPS 15 9570. Problems I'm running into is that the D6000 seems to disconnect at random multiple times per hour, making it unusable.

What I tried:
- Disabled USB from going to sleep ( https://displaylink.org/forum/showpo...8&postcount=15 )
- Installed multiple displaylink drivers (5.2.14, 5.1, 4.4.24), all with similar results.
- Nvidia proprietary drivers 430 and 390 but also Nouveau drivers
- Re-installing the OS completely (colleague does not have the issue I have with exact similar hardware and port replicator)
- Tried different port replicators (all D6000s)
- Tried using USB-A instead of USB-C. It seems to be less with USB-A but the issue is still present at least once a hour.

I'm probably missing something very obvious that noone else seems to have because my colleague does not have any issues.
Last thing I thought of was the when the laptop is fully charged via usb-c it will disconnect the usb-c and thus the monitors as well. But I just had the same issue again with 95% battery.

Attached log files from DL support tool.


Update:
Noticed that when the monitors go off that Displays in settings still sees the 2 monitors connected to the D6000. Mouse and keyboard also still work.

Update2:
Did some more testing and it's going well for the last 2 hours (issue occurred about every 30 minutes). What I did/applied:

#### installed Displaylink driver 5.1.26

#### Disable USB AutoSuspend
* `sudo gedit /etc/default/tlp` and change the below value from `1` to `0`

```
USB_AUTOSUSPEND=0
```

* `sudo gedit /etc/udev/rules.d/01-usb-dock.rules`. This will create a new file.

```
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="1bcf", ATTR{idProduct}=="2b95", TEST=="power/control", ATTR{power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="1bcf", ATTR{idProduct}=="0005", TEST=="power/control", ATTR{power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="1d6b", ATTR{idProduct}=="0002", TEST=="power/control", ATTR{power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="1d6b", ATTR{idProduct}=="0003", TEST=="power/control", ATTR{power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="04d9", ATTR{idProduct}=="0143", TEST=="power/control", ATTR{power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="04f3", ATTR{idProduct}=="24a1", TEST=="power/control", ATTR{power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="05e3", ATTR{idProduct}=="0608", TEST=="power/control", ATTR{power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="05e3", ATTR{idProduct}=="0610", TEST=="power/control", ATTR{power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="05e3", ATTR{idProduct}=="0620", TEST=="power/control", ATTR{power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="06c4", ATTR{idProduct}=="c411", TEST=="power/control", ATTR{power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="17e9", ATTR{idProduct}=="6006", TEST=="power/control", ATTR{power/control}="on"

#### Disable Display Power Management
* `sudo gedit /etc/X11/xorg.conf` Append the below options to the file.

```
Section "Monitor"
Identifier "DVI-I-3-2"
Option "DPMS" "false"
EndSection

Section "Monitor"
Identifier "DVI-I-2-1"
Option "DPMS" "false"
EndSection
```
In my case xorg.conf was missing. I created a xorg.conf file and placed it in /usr/share/X11


#### Disable audio suspend
* `sudo gedit /etc/pulse/default.pa`. Comment out the line indicated below.

```
### Automatically suspend sinks/sources that become idle for too long
# load-module module-suspend-on-idle
```

#### Disable USB wake in BIOS
Boot into the BIOS by pressing the F12 key as the machine turns on. Under `Power Management` >> `USB Wake Support` uncheck both boxes.

#### Ran these command to ouput to dev/null in some cases (only for XPS usb-c, for other USB you can use 2-2.1 instead of 4-1.1): (source: https://displaylink.org/forum/showth...t=65476&page=2 )
echo on | sudo tee /sys/bus/usb/devices/4-1.1/power/level > /dev/null
echo 2 | sudo tee /sys/bus/usb/devices/4-1.1/power/autosuspend > /dev/null



And I think most of these settings are not even necessary and the output to dev/null did the trick mostly.
Attached Files
File Type: zip DLSupportTool_Output_2019-07-22T17:08:46.547145.zip (983.0 KB, 0 views)

Last edited by erik070; 07-24-2019 at 01:15 PM.
erik070 is offline   Reply With Quote
Old 08-01-2019, 10:49 AM   #2
JamesH
Senior Member
 
Join Date: Jan 2012
Posts: 1,523
Default

Recommend installing the latest dock firmware from here:
https://www.dell.com/support/home/uk...sal-dock-d6000
JamesH is offline   Reply With Quote
Old 08-08-2019, 12:44 PM   #3
erik070
Junior Member
 
Join Date: Jul 2019
Posts: 2
Default

Thanks JamesH, would have tried that if it was not already working. Don't want to touch it now as it might break again. Finally had a week without dock issues, want to keep it that way.
erik070 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.