Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-02-2020, 08:46 PM   #1
wassiz
Junior Member
 
Join Date: Dec 2020
Posts: 1
Default MacOS 11 M1 DisplayLinkManager Crashes and System logs out user

UPDATE: ROSOLVED

When I first installed DisplayLinkManager everthing worked fine (Dell 1440p Monitor HDMI), then I rotated the display in Settings. The Image freezes as from another forum user.

I know read that M1 BigSur Screen Rotation is not supported right now, which is fine.

But now Display Manager Crashes and my user gets logged out of BigSur everytime I start DisplayLInkManager with Monitor attached.

Reinstalling the app didnt resolve the issue.

any suggestions? Like clean delete macos display settings or similar could help?

UPDATE:

Deleting window server plists files resolved the isssue:

/Library/Preferences/com.apple.windowserver.plist (sudo rm ...),
~/Library/Preferences/ByHost/com.apple.windowserver.blah-blah-blah.plist

Last edited by wassiz; 12-02-2020 at 09:05 PM.
wassiz is offline   Reply With Quote
Old 12-10-2020, 02:32 PM   #2
Hnswrstnllngssn
Junior Member
 
Join Date: Dec 2020
Posts: 2
Default

thank you for your post @Wassiz - I am having the same issue, but the resolution doesn’t seem to work for me.

Would you mind posting the detailed steps you took? What I did:

Uninstalled DL software
removed .plist file (there was only one in my case)
Rebooted

—-> still the same issue of crashing and logging out after starting DL manager.
Hnswrstnllngssn is offline   Reply With Quote
Old 12-10-2020, 02:50 PM   #3
kmillard
Junior Member
 
Join Date: Jun 2012
Posts: 11
Default

I do not see that file when I go to Finder - Go - Library....is it in a different spot?. thanks
kmillard is offline   Reply With Quote
Old 12-10-2020, 11:33 PM   #4
cyphun
Junior Member
 
Join Date: Dec 2020
Posts: 2
Default

First off, thanks for posting this, it helps to know that I am not alone with this issue.

I was able to find the .plist files you mentioned and removed them, but I am still experiencing the exact issue you described. Does anyone know how quickly things like this get addressed? I am really liking the M1 MacBook Pro, but not being able to use multiple monitors may be a deal breaker.
cyphun is offline   Reply With Quote
Old 12-11-2020, 12:36 AM   #5
jimmy5
Junior Member
 
Join Date: Dec 2020
Posts: 1
Default

I'm experiencing the same issue. Deleting windowserver file did not work for me.
jimmy5 is offline   Reply With Quote
Old 12-14-2020, 04:35 PM   #6
cyphun
Junior Member
 
Join Date: Dec 2020
Posts: 2
Default

Quote:
Originally Posted by cyphun View Post
First off, thanks for posting this, it helps to know that I am not alone with this issue.

I was able to find the .plist files you mentioned and removed them, but I am still experiencing the exact issue you described. Does anyone know how quickly things like this get addressed? I am really liking the M1 MacBook Pro, but not being able to use multiple monitors may be a deal breaker.
I updated to 1.2 this morning and it is still doing the same thing, just as a another data point.
cyphun is offline   Reply With Quote
Old 12-18-2020, 10:04 AM   #7
KatarzynaKowalczyk
DisplayLink Tech Support
 
KatarzynaKowalczyk's Avatar
 
Join Date: Apr 2020
Posts: 213
Default

Hello,

Thank you all for reaching out!

We'd appreciate if you could gather logfiles and detailed description of the issue you are seeing and steps already taken to find a solution.
The steps to gather the logfiles can be found here: https://support.displaylink.com/know...to-displaylink


Those along with description of the problem please email to technical-enquiries@synaptics.com or post in the response here.

Thank you,
Katarzyna
KatarzynaKowalczyk is offline   Reply With Quote
Old 12-18-2020, 10:42 AM   #8
jailbreak
Junior Member
 
Join Date: Dec 2020
Posts: 1
Default

The steps from the first post DID work for me (I rotated a display on M1 and found out it didn't work), here's what I did to recover:
  • unplugged the docking station
  • removed TWO files - yes there are two files: one is in system-wide /Library/Preferences, and the other is in your home directory - note the "~" character in beginning of the path!
    Quote:
    ~/Library/Preferences/ByHost/com.apple.windowserver*
  • rebooted
  • reconnected the dock, all works fine in landscape mode

Paste below line in the Terminal and hit Enter to see exact locations of files you need to remove:
Code:
for f in /Library/Preferences/com.apple.windowserver* ~/Library/Preferences/ByHost/com.apple.windowserver*; do echo $f; done
Hope this helps.....
jailbreak is offline   Reply With Quote
Old 12-20-2020, 05:01 PM   #9
helixpt
Junior Member
 
Join Date: Dec 2020
Posts: 10
Default

Exactly the same problem here, I'm so glad I've found this post!

I've already sent a UserVoice and was about to re-install my OS, although I've run to some complicated issues while formating an M1 mac and was fearful of doing it again just before the week starts.

I've attached a DisplayLinkInfo with the most detailed settings here that I was logging just before getting loged out after pluging in the screen.

I'm gonna try the proposed solution here and report back in a few minutes.
Attached Files
File Type: zip DisplayLinkInfo_Output_20201218_154747.zip (3.91 MB, 0 views)
helixpt is offline   Reply With Quote
Old 12-20-2020, 05:19 PM   #10
helixpt
Junior Member
 
Join Date: Dec 2020
Posts: 10
Default

Just tried it and was only able to find the file on the first location. Deleted it and it didn't work.

Btw here's the LS of the second directory:

Code:
helixpt@Andres-MBP ~ % cd /Users/helixpt/Library/Preferences/ByHost 
helixpt@Andres-MBP ByHost % Ls
com.apple.AMPLibraryAgent.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.AOSKit.RegInfo.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.AOSPushRelay.TopicInfo.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.Bluetooth.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.FaceTime.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.ManagedClient.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.QuickLookDaemon.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.accessibility.universalAccessAuthWarn.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.commcenter.csidata.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.configurationprofiles.user.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.controlcenter.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.dock.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.finder.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.identityservicesd.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.imservice.SMS.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.imservice.ids.FaceTime.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.imservice.ids.iMessage.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.loginwindow.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.screensaver.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.settings.storage.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.sharingd.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.soundpref.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.apple.systempreferences.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.logmein.COLVideo.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
com.logmein.GoToMeeting.7DF273B3-79B3-58C7-AEE1-06252AF00941.plist
Also the command to find it didn't return anything as expected, but it should be cached somewhere.

Code:
helixpt@Andres-MBP ByHost % for f in /Library/Preferences/com.apple.windowserver* ~/Library/Preferences/ByHost/com.apple.windowserver*; do echo $f; done
zsh: no matches found: /Users/helixpt/Library/Preferences/ByHost/com.apple.windowserver*
helixpt is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.