Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 07-23-2020, 06:50 PM   #1
Chuck
Junior Member
 
Join Date: Jul 2020
Posts: 2
Default DisplayLink stopped working on 18.04

Came in today and my 2 Display Link Monitors are not working.
Dock: plugable ULTC4k (USB-C 4K)
uname -a:
Code:
xxxxxxx 5.4.0-42-generic #46~18.04.1-Ubuntu SMP Fri Jul 10 07:21:24 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
What I've tried:
connecting/disconnecting monitors and USB-C cable; cycling power on dock station; re-installing drivers (5.2.14).
Error on reinstalling:
Code:
ERROR (code 3): Failed to build evdi/5.2.14. Consult /var/lib/dkms/evdi/5.2.14/build/make.log for details..
The above-mentioned log has the following:

Code:
DKMS make.log for evdi-5.2.14 for kernel 5.4.0-42-generic (x86_64)
Thu Jul 23 13:39:02 EDT 2020
make KBUILD_VERBOSE=1 SUBDIRS=/var/lib/dkms/evdi/5.2.14/build SRCROOT=/var/lib/dkms/evdi/5.2.14/build CONFIG_MODULE_SIG= -C /lib/modules/5.4.0-42-generic/build modules
make[1]: Entering directory '/usr/src/linux-headers-5.4.0-42-generic'
make -f ./Makefile syncconfig
make -f ./scripts/Makefile.build obj=scripts/basic
rm -f .tmp_quiet_recordmcount
make -f ./scripts/Makefile.build obj=scripts/kconfig syncconfig
  flex -oscripts/kconfig/lexer.lex.c -L scripts/kconfig/lexer.l
/bin/sh: 1: flex: not found
scripts/Makefile.host:9: recipe for target 'scripts/kconfig/lexer.lex.c' failed
make[3]: *** [scripts/kconfig/lexer.lex.c] Error 127
make[3]: *** Waiting for unfinished jobs....
  bison -o scripts/kconfig/parser.tab.c --defines=scripts/kconfig/parser.tab.h -t -l scripts/kconfig/parser.y
/bin/sh: 1: bison: not found
scripts/Makefile.host:17: recipe for target 'scripts/kconfig/parser.tab.h' failed
make[3]: *** [scripts/kconfig/parser.tab.h] Error 127
Makefile:594: recipe for target 'syncconfig' failed
make[2]: *** [syncconfig] Error 2
Makefile:704: recipe for target 'include/config/auto.conf.cmd' failed
make[1]: *** [include/config/auto.conf.cmd] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.4.0-42-generic'
Makefile:22: recipe for target 'all' failed
make: *** [all] Error 2
Also ran lsusb -d 17e9:
lsusb -d 17e9:
Code:
Bus 004 Device 004: ID 17e9:6012 DisplayLink
I'm attaching logs from troubleshooting tool as well.
Attached Files
File Type: zip DLSupportTool_Output_2020-07-23T13:48:54.125929.zip (70.1 KB, 2 views)

Last edited by Chuck; 07-23-2020 at 07:36 PM. Reason: Provide additional details
Chuck is offline   Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.