Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-04-2020, 11:33 PM   #1
mugiwara
Junior Member
 
Join Date: Aug 2020
Posts: 3
Default Screen tearing and lag using AMDGPU and DisplayLink with Ubuntu 20.04 LTS

Hi all. So I have been struggling with this issue some time, and I think this may be a known issue to to the DisplayLink devs, as in the stickied thread of this board for the patched version of Xorg, they mentioned "this patch is NOT applicable to AMD-only machines, for which we are currently developing a solution. We will update you when it is available.", but so far, as of the time it was posted which was early June of this year, there don't seem to be any updates on progress regarding this patch or even information on what it will entail.

On Ubuntu 20.04 LTS, using a desktop PC with an AMD RX 570 and a Ryzen 1600AF, there is a large amount of latency in video output as well as screen tearing/artifacting. This issue was actually brought up on the GitHub for EVDI, but it looks like it was only "handled" but never truly resolved. I faced this same issue using 18.04 LTS as well. The workaround solution that was discovered by the posters in that issue thread is to install the closed-source AMDGPU-PRO driver, which is not an ideal solution as a lot of the functionality of the open-source driver is missing, but I, as well as others who posted in said GitHub issue thread, however, did find that installing the closed-source driver did indeed resolve the latency and screen-tearing. One of the EVDI developers in the GitHub issue commented that "If EVDI + amdgpu-pro work OK then it might we worth checking what is happening in the open source equivalent of the AMD proprietary driver.", but that was posted in November of last year and it doesn't seem like there's been any progress since. Would it be a good plan of action to raise this issue with developers of the open-source AMDGPU driver in order to resolve this issue which is non-existent with the closed-source implementation? Do any of you have any suggestions? Or does anyone know of any development efforts I could follow surrounding this issue? It does seem to be affecting several users given as shown by the GitHub issue, and again, AMDGPU-PRO isn't really a proper solution, nor an ideal one.

EDIT: This thread seems to be the same issue as those who posted in it also reported to have AMD GPU + CPU combinations as well: https://displaylink.org/forum/showthread.php?p=90001

Last edited by mugiwara; 10-05-2020 at 08:02 AM. Reason: Edited to include additional info
mugiwara is offline   Reply With Quote
Reply

Tags
amdgpu, evdi, ubuntu 20.04

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.