Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-31-2017, 09:44 AM   #1
Bertus
Junior Member
 
Join Date: Mar 2017
Posts: 8
Exclamation going from 10.12.3 to 10.12.4 introduced issues - scrambled popup windows

i've been very happily working with 2 24" screens hooked up via a Dell D1000 doc, using the february 3rd drivers on OS X 10.12.3. on a 2012 macbook pro (non-retina)

upgraded to 10.12.4 the other day, which introduced issues that make working with this setup impossible.

issues:
- scrambled popups & other screen elements
- slow performance; dragging windows, doc magnification

The scrabled screen elements are the real problem; f.i. an 'open file' window is completely scrambled, not usable whatsoever, moving the window to the onboard screen resolves the issue.
Also, dragging elements in an application i use (Axure RP) scrambles the elements, and brings the system almost to a halt.

Tried de- and reinstalling the drivers, which at first seemed to resolve the problem, but it has since returned. Perhaps a cold boot/ restart solved it temporarily, and disconnecting/reconnecting with the dock causes the problem to reappear? (this happens several times a day, on 10.12.3 without issues)

i'll update this post with a screenshot.

Is there any info on an upcomming driver update that might resolve this issue? other ideas?
Attached Images
File Type: jpg Pasted Graphic.jpg (17.8 KB, 6 views)

Last edited by Bertus; 04-03-2017 at 07:07 AM. Reason: image upload
Bertus is offline   Reply With Quote
Old 03-31-2017, 02:16 PM   #2
pmoston
Junior Member
 
Join Date: Mar 2017
Posts: 5
Exclamation Sames issues with Lenovo Thinkpad USB 3.0 Ultra Dock

I am having the same issues with my Thinkpad USB 3.0 Ultra Dock connected to my mid 2012 Macbook Pro Retina. I have two external DELL Monitors connected to the Ultra Dock. Some windows get completely scrambled. Particularly Parallels & Firefox but also any kind of progress bars. All windows are fine on the built-in laptop screen.
This please needs to be addressed ASAP as this renders the machine almost useless.

I have attached screenshots from my Parallels window both from an external monitor and moved over to the built in monitor. The scrambling also happens in full screen mode on the external monitors.

I have installed the latest version (3rd Feb. 2017).
Attached Images
File Type: jpg Bildschirmfoto 2017-03-31 um 16.06.54.jpg (15.3 KB, 2 views)
File Type: jpg Bildschirmfoto 2017-03-31 um 16.07.06.jpg (10.2 KB, 1 views)
pmoston is offline   Reply With Quote
Old 04-01-2017, 01:59 AM   #3
tjgrant
Junior Member
 
Join Date: Apr 2017
Posts: 4
Default

I'm seeing the same thing; here's Parallels 12 and VLC 2.1.1 being mirrored on the native monitor and the DisplayLink monitor.

In the DisplayLink monitor, both apps show garbled visuals.

I had upgraded the DisplayLink driver to version 3.0 and saw this.
I tried downgrading the DisplayLink driver to version 2.6 and I see the same results.
Attached Images
File Type: jpg Screen Shot 2017-03-31 at 6.45.07 PM.jpg (18.9 KB, 1 views)
File Type: jpg Screen Shot 2017-03-31 at 6.46.17 PM.jpg (19.8 KB, 4 views)
tjgrant is offline   Reply With Quote
Old 04-02-2017, 07:01 AM   #4
Carlo
Mac Team
 
Join Date: Feb 2009
Posts: 606
Default

Hi All,

This is almost certainly a regression in the SW renderer in 10.12.4.
If this is confirmed, we can't do anything about this in the driver and it's very important to raise bugs with Apple as soon as possible to get this rectified earlier.

You can use bugreporter.apple,com or if you are in a corporate, ask for a fix from your support representative.
We'll add our own bug ID for these rendering issues to the Sierra list. It was getting much better but unfortunately there are a couple of new regressions now.

Kind regards,
Carlo
Carlo is offline   Reply With Quote
Old 04-03-2017, 07:30 AM   #5
Bertus
Junior Member
 
Join Date: Mar 2017
Posts: 8
Default bugreport

bug reported via bugreport.apple.com: 31397501
Bertus is offline   Reply With Quote
Old 04-03-2017, 08:06 AM   #6
pmoston
Junior Member
 
Join Date: Mar 2017
Posts: 5
Default Bug reported to apple

Issue #31397880
pmoston is offline   Reply With Quote
Old 04-03-2017, 06:20 PM   #7
moronim
Junior Member
 
Join Date: Apr 2017
Posts: 1
Default

submitted bug report #31406921
moronim is offline   Reply With Quote
Old 04-03-2017, 08:00 PM   #8
daemon
Junior Member
 
Join Date: Jan 2016
Posts: 3
Angry Same issue

I have the same issue on 3x 19 inch monitors.

But for the most part any window dragged onto those monitors exhibit the scrambled windows.

I tried going back to the older driver but that did not work.

Any planned beta's that could address this?
daemon is offline   Reply With Quote
Old 04-04-2017, 09:58 PM   #9
ourzoo
Junior Member
 
Join Date: Sep 2015
Posts: 13
Default

Same issue here. The monitor directly connected to my MacBookPro is fine. It's only the one connected with Display Link. And it's also only when I try using Windows via Parallels 12. So this pretty much kills productivity for me at home or in the office as I have the same set up at both locations. Based on past bugs being reported, how long might this take to be rectified? Really pissed.....
ourzoo is offline   Reply With Quote
Old 04-05-2017, 09:39 AM   #10
DisplayLurker
Junior Member
 
Join Date: Apr 2017
Posts: 1
Exclamation

Exactly the same issue, I just updated to Mac Sierra 10.12.4.

Connected with 3 external displays and a DELL D3100 Dock.

Was perfect 2 days ago, now is horrible.

Word = unusable
Parallels = unusable
MS Windows = unusable
MS Project = unusable
Plus numerous other applications

I hope there is a solution soon, otherwise I'll have to bin the DELL dock using DisplayLink technology at it's heart and use only one external monitor connected directly to Thunderbolt port.

It's a pity because it was/is a wonderful solution which suited my needs and budget. Don't really want to spend $3000 to get a new mac with 4 thunderbolt ports to run 3 external displays.

Thanks.


31449613 (Apple Bug report was submitted successfully).

Last edited by DisplayLurker; 04-05-2017 at 09:43 AM.
DisplayLurker is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.