Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-09-2022, 02:47 AM   #1
GlenCooper
Junior Member
 
Join Date: Aug 2020
Location: Reston, VA
Posts: 2
Exclamation WL-UG3501H install failed on Pop!_OS 20.04

I purchased a WL-UG3501H hoping to add another monitor to my laptop via USB 3.0 port to HDMI cable to monitor.

Laptop is 2021 MSI Modern 14 B5M-053 (AMD Ryzen 5 5500U, 64GB RAM, 2TB Gold P31 NVMe SSD, UMA, 14" FHD, Pop!_OS 22.04).

It's saying "Please disconnect the dock before continuing", but I'm unsure what to do. There is no dock. Any help here would be appreciated. Thanks in advance.

sats@stephano:~/DisplayLink$ lsb_release -a
No LSB modules are available.
Distributor ID: Pop
Description: Pop!_OS 22.04 LTS
Release: 22.04
Codename: jammy
sats@stephano:~/DisplayLink$ dkms status
system76/1.0.14~1643391291~22.04~78ede46, 5.17.5-76051705-generic, x86_64: installed
system76/1.0.14~1643391291~22.04~78ede46, 5.19.0-76051900-generic, x86_64: installed
system76_acpi/1.0.2~1659568831~22.04~a88dcce, 5.17.5-76051705-generic, x86_64: installed (original_module exists)
system76_acpi/1.0.2~1659568831~22.04~a88dcce, 5.19.0-76051900-generic, x86_64: installed (original_module exists)
system76-io/1.0.2~1655490480~22.04~0217576, 5.17.5-76051705-generic, x86_64: installed
system76-io/1.0.2~1655490480~22.04~0217576, 5.19.0-76051900-generic, x86_64: installed
wireguard/1.0.20210606: added
sats@stephano:~/DisplayLink$ lsusb
Bus 004 Device 002: ID 17e9:4301 DisplayLink USB3 to HDMI
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 5986:211c Acer, Inc HD Webcam
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 002: ID 8087:0029 Intel Corp. AX200 Bluetooth
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
sats@stephano:~/DisplayLink$ sudo ./displaylink-driver-5.4.1-55.174.run
Verifying archive integrity... 100% All good.
Uncompressing DisplayLink Linux Driver 5.4.1-55.174 100%
DisplayLink Linux Software 5.4.1-55.174 install script called:
Distribution discovered: Pop!_OS 22.04 LTS
Detected running Xorg session and connected docking station
Please disconnect the dock before continuing
Installation terminated.
sats@stephano:~/DisplayLink$
GlenCooper is offline   Reply With Quote
Old 10-09-2022, 02:57 AM   #2
GlenCooper
Junior Member
 
Join Date: Aug 2020
Location: Reston, VA
Posts: 2
Smile Found the solution!

Found solution to this in https://www.displaylink.org/forum/sh...ad.php?t=67148

All that was needed was to do:
sudo dpkg -i xserver-xorg-core_1.20.8-2ubuntu2_amd64.deb
followed by a reboot, and voila! This WL-UG3501H adapter is now working as expected and I have another display to use with my laptop.
GlenCooper is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.