Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-01-2024, 03:25 PM   #1
Steev
Junior Member
 
Join Date: Feb 2024
Posts: 1
Default Laggy Display Performance on ThinkPad

Hello and thank you for your time -

I have the following machine:
  • ThinkPad T15g Gen 1 with an Nvidia 2080 Super 8G
    Built-in Intel P630 graphics
    USB-C Thunderbolt 3 (40Gbit) connection to a DisplayLink 4K 60hz dual-display adapter on native USB-C
    Windows 11 Pro 23H2
    DisplayLink software 11.2 M0, after running the cleaner app I found in another forum post

Issue
While the displays do work, the response time is nothing like it is on the native 4k 60hz display of the laptop. For example, my screensaver is the default Windows 3D text. As it displays, it clearly stutters. Also, if I left-click the desktop and drag the semi-transparent selection rectangle around the screen, the animation is very choppy. This is apparent on both screens and the issue is visible in video playback. Gaming also has a noticeable input delay from my keyboard and mouse.

Switching the laptop (in the BIOS) to "discreet graphics only" does not improve performance, and it also removes Windows' ability to detect (and adjust the position of) multiple displays, so I run in Hybrid to get the adjustment option back.

I have attempted both the Lenovo-approved drivers and the factory ones available from both Intel and NVIDIA.

I am running a high-performance power profile.

Am I doing something wrong?

Thank you!
Steve
Steev is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.