Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 09-29-2023, 03:45 PM   #1
emilyethomson82
Junior Member
 
Join Date: Sep 2023
Posts: 1
Default Help needed (DisplayLink no longer works with Mac)

Hi - I'm not technical and don't even know where to start in this forum troubleshooting, so hoping someone can message me and help directly. I have a MacBookPro that used to work when I connected to the display link port to sync with my two external monitors, but doesn't any more.

MacBook Pro (13-inch, M2, 2022)
Apple M2 Chip
macOS Monterey (Version 12.4)

I even tried to download the latest drivers. It's been a few months since I last tried (and it worked), so I'm not sure if my OS updated in the interim and that's what happened, but all I know is I've unplugged and replugged everything in and the external displays don't connect or even show up when I select Displays from the System Control section.

Can anyone tell me what to do, or point me in the right direction?

Thanks,
Emily
emilyethomson82 is offline   Reply With Quote
 

Tags
macos monterey

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.