Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-02-2023, 01:57 PM   #1
tdevor
Junior Member
 
Join Date: Aug 2023
Posts: 2
Default Display Link on Work Computer (Please Help!)

Hello Everyone,

I have a work computer that is running gentoo with 6.1.41 kernel.

I've successfully installed:

x11-drivers/displaylink-driver-5.6.1
x11-drivers/evdi-1.13.1

All the USB peripherals (Keyboard, mouse, mic, cam) work perfectly however, my computer is unable to successfully start DisplayLink:

PHP Code:
Kernel6.1.41 
PHP Code:
 2.365907usb 3-2.2ProductThinkPad Hybrid USB-C with USB-A Dock 
PHP Code:
xrandr --listproviders
Providers
number 2
Provider 0
id0x278 cap0x1Source Output crtcs0 outputs0 associated providers1 name:NVIDIA-0
Provider 1
id0x2a0 cap0xfSource OutputSink OutputSource OffloadSink Offload crtcs3 outputs6 associated providers1 name:modesetting 
PHP Code:
systemctl status dlm
dlm.service DisplayLink Manager Service
     Loaded
loaded (/lib/systemd/system/dlm.serviceenabledpresetdisabled)
     
Activeactive (runningsince Tue 2023-08-01 16:10:00 EDT17h ago
    Process
4158 ExecStartPre=/sbin/modprobe evdi (code=exitedstatus=0/SUCCESS)
   
Main PID4178 (DisplayLinkMana)
        
CPU2.871s
     CGroup
: /system.slice/dlm.service
             
`-4178 /opt/displaylink/DisplayLinkManager 
I have spent 2 weeks trying to get the DisplayLink working with my external monitors however not able to do so. Can someone please help me?
tdevor is offline   Reply With Quote
Old 08-03-2023, 11:56 AM   #2
lspintzyk
Member
 
lspintzyk's Avatar
 
Join Date: Feb 2013
Posts: 65
Default

x11-drivers/displaylink-driver-5.6.1 should work with evdi-1.12 not evdi-1.13
Sorry for that if this is not clearly visible. It is on our backlog to make it easier for the future.

You might need to run this
xrandr --setprovideroutputsource 1 0
as it is described here.
https://wiki.archlinux.org/title/DisplayLink
lspintzyk is offline   Reply With Quote
Old 08-03-2023, 12:47 PM   #3
tdevor
Junior Member
 
Join Date: Aug 2023
Posts: 2
Default

Quote:
Originally Posted by lspintzyk View Post
x11-drivers/displaylink-driver-5.6.1 should work with evdi-1.12 not evdi-1.13
Sorry for that if this is not clearly visible. It is on our backlog to make it easier for the future.

You might need to run this
xrandr --setprovideroutputsource 1 0
as it is described here.
https://wiki.archlinux.org/title/DisplayLink
Thank you for the reply! Please note that I am using Kernel 6.1, evdi-1.12 does not compile with this kernel version.
tdevor is offline   Reply With Quote
Old 08-04-2023, 01:48 PM   #4
lspintzyk
Member
 
lspintzyk's Avatar
 
Join Date: Feb 2013
Posts: 65
Default

FYI We are not supporting Genotoo package.

Then you should use newer x11-drivers/displaylink-driver that matches evdi-1.13 provided by Gentoo.
If it is not available you need to contact package maintainer.

Otherwise you can use .run installer afailable on displaylink download page:
https://www.synaptics.com/products/d...wnloads/ubuntu
There is something like "DisplayLink USB Graphics Software for Ubuntu" but it should work with Gentoo.
lspintzyk is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.