Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-23-2019, 03:17 PM   #1
goofy79
Junior Member
 
Join Date: May 2019
Posts: 2
Default centOS 7 support please

Hello,

i tried to install the DisplayLink Driver on my centOS 7 laptop, but without any success

If i start the ./displaylink-driver-5.1.26.run i get the following error
Code:
Verifying archive integrity...  100%   All good.
Uncompressing DisplayLink Linux Driver 5.1.26  100%  
DisplayLink Linux Software 5.1.26 install script called: install
Distribution discovered: "CentOS Linux release 7.6.1810 (Core) "
Installing
Configuring EVDI DKMS module
Registering EVDI kernel module with DKMS
Building EVDI kernel module with DKMS
ERROR (code 3): Failed to build evdi/5.1.26. Consult /var/lib/dkms/evdi/5.1.26/build/make.log for details..
in the log file i can find ...
Code:
make[1]: Entering directory `/usr/src/kernels/5.1.4-1.el7.elrepo.x86_64'
make \
 \
-f /usr/src/kernels/5.1.4-1.el7.elrepo.x86_64/Makefile modules
/usr/src/kernels/5.1.4-1.el7.elrepo.x86_64/Makefile:205: ================= WARNING ================
/usr/src/kernels/5.1.4-1.el7.elrepo.x86_64/Makefile:206: 'SUBDIRS' will be removed after Linux 5.3
/usr/src/kernels/5.1.4-1.el7.elrepo.x86_64/Makefile:207: Please use 'M=' or 'KBUILD_EXTMOD' instead
/usr/src/kernels/5.1.4-1.el7.elrepo.x86_64/Makefile:208: ==========================================
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (		\
echo >&2;							\
echo >&2 "  ERROR: Kernel configuration is invalid.";		\
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";	\
echo >&2 ;							\
/bin/false)
Code:
/var/lib/dkms/evdi/5.1.26/build/evdi_drv.c:45:2: Warnung: Initialisierung von inkompatiblem Zeigertyp [standardmäßig aktiviert]
  .fault = evdi_gem_fault,
  ^
/var/lib/dkms/evdi/5.1.26/build/evdi_drv.c:45:2: Warnung: (nahe der Initialisierung für »evdi_gem_vm_ops.fault«) [standardmäßig aktiviert]
/var/lib/dkms/evdi/5.1.26/build/evdi_connector.c:124:16: Fehler: »drm_helper_probe_single_connector_modes« ist hier nicht deklariert (nicht in einer Funktion)
  .fill_modes = drm_helper_probe_single_connector_modes,
                ^
/var/lib/dkms/evdi/5.1.26/build/evdi_painter.c: In Funktion »evdi_painter_connect«:
/var/lib/dkms/evdi/5.1.26/build/evdi_painter.c:675:2: Fehler: Implizite Deklaration der Funktion »drm_helper_hpd_irq_event« [-Werror=implicit-function-declaration]
  drm_helper_hpd_irq_event(evdi->ddev);
  ^
/var/lib/dkms/evdi/5.1.26/build/evdi_main.c: In Funktion »evdi_driver_setup«:
/var/lib/dkms/evdi/5.1.26/build/evdi_main.c:54:2: Fehler: Implizite Deklaration der Funktion »drm_kms_helper_poll_init« [-Werror=implicit-function-declaration]
  drm_kms_helper_poll_init(dev);
  ^
/var/lib/dkms/evdi/5.1.26/build/evdi_main.c: In Funktion »evdi_driver_unload«:
/var/lib/dkms/evdi/5.1.26/build/evdi_main.c:95:2: Fehler: Implizite Deklaration der Funktion »drm_kms_helper_poll_fini« [-Werror=implicit-function-declaration]
  drm_kms_helper_poll_fini(dev);
  ^
make[3]: *** [/var/lib/dkms/evdi/5.1.26/build/evdi_connector.o] Fehler 1
make[3]: *** Warte auf noch nicht beendete Prozesse...
cc1: Einige Warnungen werden als Fehler behandelt
make[3]: *** [/var/lib/dkms/evdi/5.1.26/build/evdi_main.o] Fehler 1
cc1: Einige Warnungen werden als Fehler behandelt
make[3]: *** [/var/lib/dkms/evdi/5.1.26/build/evdi_painter.o] Fehler 1
   ./tools/objtool/objtool check  --module --retpoline /var/lib/dkms/evdi/5.1.26/build/evdi_encoder.o
my env is a 5.1.4-1.el7.elrepo.x86_64 kernel

BR
goofy79 is offline   Reply With Quote
Old 05-24-2019, 01:19 PM   #2
mlukaszek
Senior Member
 
mlukaszek's Avatar
 
Join Date: Feb 2010
Posts: 386
Default

The 5.1 kernel is not yet supported by the most recent DisplayLink driver release, but it is already supported in the devel branch of evdi (https://github.com/DisplayLink/evdi) which we will be using in future Linux driver release.

You can compile evdi from github manually and use it with the 5.1 DisplayLink driver, although you would need to extract installer components and modify the installer script to cope with it (i.e. so it doesn't attempt to build the bundled evdi tarball).

Cheers,
Michal
mlukaszek is offline   Reply With Quote
Old 02-26-2023, 11:24 PM   #3
KellyAndrews
Junior Member
 
Join Date: Feb 2023
Posts: 1
Default

Hey there. Though it's been long since you posted here, I'd like to know if you've fixed that problem. I've faced a similar issue, so I'd like to know if you can help me.
KellyAndrews is offline   Reply With Quote
Old 02-27-2023, 03:17 PM   #4
WillowDelacruz
Junior Member
 
Join Date: Feb 2023
Posts: 1
Default

Hello there! I stumbled upon your old forum post regarding the trouble you were experiencing in installing the DisplayLink driver on your CentOS 7 laptop. Have you considered checking if your CentOS 7 version is still covered by TuxCare's Extended Lifecycle Support? They offer support for CentOS 7, which includes bug fixes and security updates. You should visit their website at https://tuxcare.com/extended-lifecyc...ended-support/ to learn more about it. I hope this information helps! Don't hesitate to reach out to me if you have any other questions or if you have found a solution that worked for you.

Last edited by WillowDelacruz; 03-01-2023 at 02:58 PM.
WillowDelacruz is offline   Reply With Quote
Old 07-31-2023, 06:56 AM   #5
ZekeMX
Junior Member
 
Join Date: Jul 2021
Posts: 4
Default

Quote:
Originally Posted by KellyAndrews View Post
Hey there. Though it's been long since you posted here, I'd like to know if you've fixed that problem. I've faced a similar issue, so I'd like to know if you can help me.
Take a look at this link.

https://github.com/displaylink-rpm/d...pm/tree/master

I've tested it and unpack the official ubuntu package and creates installable rpm packages that works great on fedora, Unfortunately they don´t work with my mandriva fork since it creates packages with Fedora SystemD scriplets not compatible with my distro.
ZekeMX is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.