Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-23-2023, 06:44 PM   #1
ssaner
Junior Member
 
Join Date: May 2023
Posts: 2
Default HDMI Port Locking Up

Running Kubuntu 22.04 on a Lenovo X1 Thinkpad and using a Totu 16-in-1 dock that supports 3 displays (2 display port and 1 hdmi).

For a few weeks everything was fine, but in the last few days the HDMI port, for lack of better words, locks up.

After a reboot, all three displays work for a while. Then suddenly the display connected to the HDMI port freezes with whatever was showing on the display. This happens whether or not I've interacted with that display (though it might happen faster if I do). Power cycling the monitor has no effect. I can unplug and replug the HDMI cable and that will reset it and it will work for a while. I can unplug and replug the entire dock and that seems to fix it for a while too. Rebooting the computer fixes for a while. No matter what I do, 100% of the time after a while that display freezes.

Again, this did not happen at all for the first several weeks that I started using this dock.

I'm trying to figure out if this is a driver issue or if perhaps something has happened to that port on a hardware level.

Thanks for any suggestions.
ssaner is offline   Reply With Quote
Old 06-22-2023, 01:59 PM   #2
ssaner
Junior Member
 
Join Date: May 2023
Posts: 2
Default Update

Still having problems with the DisplayLink driver on Kubuntu 22.04.

When the HDMI port locks up, I have found that I can recover by restarting the displaylink-driver service:

sudo systemctl restart displaylink-driver.service

I usually have to restart it around 10-15 minutes after I start using the system in the morning. And often once or twice more throughout the day. It seems to kind of stabilize and is fine for the last few hours of the day.

I think it is a driver issue because I had a chance to try using another docking station of the same brand/model the other day, and the same problems existed.

I tried downgrading the driver to a previous version and that was even worse (I couldn't get more than one or two monitors to work at all).


The other thing that I have noticed is that the DisplayLinkManager process runs at a pretty high CPU utilization, generally from around 10% to 30%. It is generally the top process as shown with the top application.
ssaner is offline   Reply With Quote
Old 06-23-2023, 07:41 AM   #3
ScreamCZE
Member
 
Join Date: Jun 2018
Posts: 47
Default

If I found the correct dock, then it does look like the HDMI port is not based on DisplayLink (Just DP outputs are) - so I do not think that DisplayLink can help ou here.
ScreamCZE is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.