Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-07-2021, 02:54 AM   #31
RobstaRobotard
Junior Member
 
Join Date: Mar 2020
Posts: 11
Default

For those interested:

This was the link to my installer using the fix that was working fine for 5.10.4

https://github.com/robotard/setup-ub...kdownloader.sh

Shouldn't be private now...
RobstaRobotard is offline   Reply With Quote
Old 01-07-2021, 07:39 AM   #32
andy_g
Junior Member
 
Join Date: Jan 2014
Posts: 16
Default

Quote:
Originally Posted by RobstaRobotard View Post
Ooh, not intentionally, but just a note that the EVDI one is broken again on 5.10.5...Works fine on 5.10.4 though...
What changed, in simple terms
andy_g is offline   Reply With Quote
Old 01-11-2021, 01:01 AM   #33
RobstaRobotard
Junior Member
 
Join Date: Mar 2020
Posts: 11
Default

Quote:
Originally Posted by andy_g View Post
What changed, in simple terms
I've posted support logs a few posts above... Display worked in 5.10.4, then 5.10.5 suddenly not...
RobstaRobotard is offline   Reply With Quote
Old 01-14-2021, 06:36 AM   #34
drlele
Junior Member
 
Join Date: Jan 2021
Posts: 3
Default

Quote:
Originally Posted by nvergontbij View Post
Tested on Ubuntu 20.04, kernel version 5.10.2 (-surface).
Hope that helps.
Just tried this on Kubuntu 20.04.1 with kernel version 5.10.0 and got:

Code:
DisplayLink Linux Software 5.3.1.34 install script called: install
Distribution discovered: Ubuntu 20.04.1 LTS
Unsatisfied dependencies. Missing component: Linux headers for running kernel, 5.10.0-051000-generic.
Trying to install kernel 5.10.2 now...

Different issue on 5.10.2: it seemed to install fine but couldn't find the evdi 1.7.2 binaries. Sadly I lost the log, will try again later.

Last edited by drlele; 01-14-2021 at 07:18 AM.
drlele is offline   Reply With Quote
Old 01-22-2021, 06:49 AM   #35
andy_g
Junior Member
 
Join Date: Jan 2014
Posts: 16
Default

Hey all

Just to let you know everything is now working fine again on the latest 5.10.9 kernel for me after not working on 5.10.5 but working on 5..10.4 as per my earlier post.
andy_g is offline   Reply With Quote
Old 01-23-2021, 04:39 PM   #36
drlele
Junior Member
 
Join Date: Jan 2021
Posts: 3
Default

Quote:
Originally Posted by andy_g View Post
Just to let you know everything is now working fine again on the latest 5.10.9 kernel for me
Did you install normally or with the method from this thread?

If with the method: which evdi version did you use?
drlele is offline   Reply With Quote
Old 01-27-2021, 08:28 AM   #37
andy_g
Junior Member
 
Join Date: Jan 2014
Posts: 16
Default

Quote:
Originally Posted by andy_g View Post
Yep that works perfect for me on 5.10.4 0 - thanks so much!
See my previous post @drlele
andy_g is offline   Reply With Quote
Old 02-25-2021, 09:05 AM   #38
drlele
Junior Member
 
Join Date: Jan 2021
Posts: 3
Default It works now!

Finally it worked with kernel 5.9.16 and with evdi 1.7.x on my Thinkpad T490!

Neither 5.8 or 5.10 worked at all with the same procedure, so I guesse trial and error was necessary
drlele is offline   Reply With Quote
Old 03-08-2021, 10:53 PM   #39
Crashdummy
Junior Member
 
Join Date: Nov 2020
Posts: 8
Default

Anyone got it to work with 5.11.2 ??

I could do everything just fine until recently when I upgraded my kernel to 5.11.2

I can't even install evdi anymore...

Code:
DisplayLink Linux Software 5.3.1.34 install script called: install
Distribution discovered: Pop!_OS 20.10

Installing

[ Installing EVDI ]
[[ Installing EVDI DKMS module ]]

Creating symlink /var/lib/dkms/evdi/1.7.2/source ->
                 /usr/src/evdi-1.7.2

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
make -j8 KERNELRELEASE=5.11.2-surface all INCLUDEDIR=/lib/modules/5.11.2-surface/build/include KVERSION=5.11.2-surface DKMS_BUILD=1...(bad exit status: 2)
ERROR (dkms apport): binary package for evdi: 1.7.2 not found
Error! Bad return status for module build on kernel: 5.11.2-surface (x86_64)
Consult /var/lib/dkms/evdi/1.7.2/build/make.log for more information.
ERROR: Failed to install evdi/5.3.1.34 to the kernel tree.
Crashdummy is offline   Reply With Quote
Old 03-24-2021, 05:52 PM   #40
Crashdummy
Junior Member
 
Join Date: Nov 2020
Posts: 8
Default Can at least install now

I was able to install it using the changes of this PR.
https://github.com/DisplayLink/evdi/pull/269

Code:
unzip 'DisplayLink*.zip'
chmod +x displaylink-driver-5.3.1.34.run
./displaylink-driver-5.3.1.34.run --noexec --keep

git clone --branch linux-5.11-ftbfs-fix https://github.com/piso77/evdi.git
cd evdi 
tar cf evdi.tar.gz *
cp evdi.tar.gz ../displaylink-driver-5.3.1.34

cd ../displaylink-driver-5.3.1.34
sudo ./displaylink-installer.sh install
Displaylink yet not working....
evdi is installed and DisplayLinkManager running.
Crashdummy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.