Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-10-2017, 05:08 PM   #1
saper_2
Junior Member
 
Join Date: Oct 2017
Location: PL
Posts: 3
Default Black screen with cursor after Windows 10 Creators update

Hello,

I have a not sooo old laptop (Samsung np355v5c: amd trinity a10-4600 7660+7600M - dual graphic ).

I was happy with my USB3.0-to-DVI adapter which is build on DisplayLink DL-3100-N and my 3-monitor setup (1st: main laptop display, 2nd: on HDMI NEC 243WM, 3rd: on usb3.0-dvi adapter NEC 243WM)...
But something poked me to update Win10 to Creators Update (to 1703, build: 15063.608) ...
And Problems started...
At first (after update) I didn't need to run 3 display - so I didn't connected my 3rd monitor, but recently I had need for 3rd one so I connected...
When I moved window to 3rd display - no window, but I saw only cursor when moved mouse, so I started googling...
I did clean removal (removed old DisplayLink drivers, and using EndUserCleaner.exe ) , then downloaded newest drivers and installed them, I did even changed in CCC in "Switchable Graphic Application Settings" for DisplayLinkUI.exe to Power Saving .
After installing drivers I connected the DL-3100 adapter and the desktop wallpaper shown up, but when I moved window on the 3rd monitor the window itself was black, and when I was moving it was tearing the wallpaper... So I rebooted windows, and now I'm back to the beginning, black desktop with mouse cursor only...

I know I'm stupid installing creators update, but... too late ... I'd grateful for help...
Attached Files
File Type: zip SAPER-PC_20171010_002838.zip (944.1 KB, 3 views)
saper_2 is offline   Reply With Quote
Old 10-11-2017, 06:58 AM   #2
Wim
Senior Member
 
Join Date: Feb 2009
Posts: 1,564
Default

Hi

Thanks for the logs. I think the problem could be indirectly caused by the AMD graphics cards you have. We don't have a reliance on the graphics card in Windows 10, instead the OS uses the graphics card driver to compose the display to send to DisplayLink devices.

However the date of the AMD graphics drivers are 2015, which is a year before this new architecture for DisplayLink was added to Windows 10. I suspect there are bugs in the AMD graphics driver which are being exposed by the OS when it uses it to render displays for DisplayLink.

I suspect the drivers for these graphics cards are no longer maintained by AMD, so I don't think there will be a fix from AMD for this.

Wim
Wim is offline   Reply With Quote
Old 10-14-2017, 01:19 PM   #3
saper_2
Junior Member
 
Join Date: Oct 2017
Location: PL
Posts: 3
Default

HI,

I suspected amd drivers from start (I did a lot of googling before posting on forum). But the interesting thing is that: everything was working fine before I run creators update, but I was using at that time a windows drivers for my graphic card(s) (301 suffix version - If my memory serve right). But I had to upgrade them to AMD because of 3d cad software that I use (it was complaining that I have old drivers and it was switching to "software render mode").
I'll go back (in few days) to windows drivers and see if this will change anything...

Last edited by saper_2; 10-14-2017 at 01:21 PM.
saper_2 is offline   Reply With Quote
Old 12-07-2021, 10:50 PM   #4
harsha
Junior Member
 
Join Date: Nov 2021
Posts: 2
Default

hey I was wondering if you still have this issue, i have same issue with my vaio ATI-6630M Intel-HD3000, I started using the dock recently hence I have black screen from beginning :-(
harsha is offline   Reply With Quote
Old 12-07-2021, 11:22 PM   #5
saper_2
Junior Member
 
Join Date: Oct 2017
Location: PL
Posts: 3
Default

Hi,

Nope, no luck - still same problem .
I think M$ broke down something in WDM interface (or changed, or disabled),and since I have (and you) a old GPU that won't get any drivers updates, so there won't be a fix.


OT: I started to think about buying new PC in upcoming year - my current laptop is getting too slow, and starting to fall apart .I'm considering: refub Dell Workstation or something brand new built from pieces. In my plans there is a one "tiny thorn": (right now) those idiotic prices for decent GPUs

I'd suggest you to think on new hardware too. Unless you can switch to Linux
saper_2 is offline   Reply With Quote
Reply

Tags
black display, mouse cursor, windows 10 (1703)

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.