Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-01-2020, 09:39 AM   #1
Jan Hubený
Junior Member
 
Join Date: Oct 2020
Posts: 3
Default dIsplayLinkManager high CPU load

Hello,

I have fresh installation of Ubuntu 20.04 LTS oin Dell Vostro 5590 with integrated Intel UHD graphics and dedicated Nvidia GP108M [GeForce MX250]. I use the Dell D6000 universal docking station.

In order to have the display link working correctly with integrated graphic card I follow the post

https://www.displaylink.org/forum/sh...ad.php?t=67148

The display link is now working, however the displayLinkManager process generates huge CPU load after each event (mouse move, change of the displayed content after key press, change of the displayed content by program - htop, video player, etc). The high CPU load is noticeable on all 8 threads.

I suppose, that this is not normal. Exists there some workaround?

Thank you,

Jan Hubeny
Attached Files
File Type: zip DLSupportTool_Output_2020-10-01T10:36:56.919848.zip (789.3 KB, 0 views)
Jan Hubený is offline   Reply With Quote
Old 10-01-2020, 04:57 PM   #2
MaxAsdoria
Junior Member
 
Join Date: Oct 2020
Posts: 1
Default

Hello !

I've the same problem with a Dell Vosto 15 3000 ( And 2 screens) .

CPU going at 50-70% when i do something.

Thanks for help
MaxAsdoria is offline   Reply With Quote
Old 10-08-2020, 01:06 PM   #3
dampel
Junior Member
 
Join Date: Sep 2020
Posts: 3
Default

Hi,
You can try steps from this post:
https://displaylink.org/forum/showthread.php?t=67344
But if you have possibility change you docking station to that witch not require DisplayLink.

I'm looking for such docking station.

Best Regards
dampel
dampel is offline   Reply With Quote
Old 10-12-2020, 02:31 PM   #4
mauromol
Junior Member
 
Join Date: Mar 2015
Posts: 3
Default

Same problem here with Kubuntu 20.04. Monitoring this thread in case anyone from DisplayLink posts something.
mauromol is offline   Reply With Quote
Old 10-13-2020, 05:44 PM   #5
devnull10
Junior Member
 
Join Date: Oct 2020
Posts: 2
Default

Also have this problem, Ubuntu 20.04 on a Lenovo laptop, AMD Raedon Graphics card. Installed the latest version of the driver, however when I plug in the displaylink the DisplayLinkManager process immediately starts eating up CPU. If I drag anything onto the other screen it jumps to well over 100% and starts really stuttering. Seems like a very common issue based on the number of posts I've seen, but unfortunately no resolution!
devnull10 is offline   Reply With Quote
Old 10-14-2020, 12:36 PM   #6
fitter
Junior Member
 
Join Date: Jul 2020
Posts: 8
Default

Actually I do not remember if I checked the CPU usage, but that might be the source why the screen was very laggy and audio choppy. I have system with AMD CPU+GPU and Ubuntu 20.04

Idk whats the status of this project, but I need to admit that since the release of 20.04 the DisplayLink team is not very audible on this forum. Recently there were no replies from them at all.
So well, lets hope a new kernel 5.8 will bring the fix for our issues and this project will not become an abandonware
fitter is offline   Reply With Quote
Reply

Tags
high cpu load, intel, nvidia, ubuntu 20.04

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.