Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-02-2022, 03:21 PM   #1
FrancescoBoxxo
Junior Member
 
Join Date: Dec 2022
Posts: 1
Default Drivers not working on Sabrent PD Docking station

Hello I'm having some issues with the Sabrent PD Docking station.
The model number for the device is WS-WSPD-EU and its drivers are DisplayLink.

I keep having this issue having it connected to an Asus ROG Strix G512 LV.
The device disconnects from the OS and doesn't get recognized anymore until a new Windows install is done and even so, sometimes it doesn't even get recognized on a fresh install.

I've tried troubleshooting it by myself but I had no luck.
The drivers I tested are the ones in your download page:
https://www.synaptics.com/products/d...nloads/windows
I currently tested
W10 Home with BIOS version 314 and Synaptic release 10.3 M0 .
W10 Pro with BIOS version 314 10.2 M2 .
W11 Home with BIOS version 314 10.3 M0 .
W11 Pro with BIOS version 314 and 312 and Synaptic release: 10.2 M2 but also 10.3 M0 (I also tried the corporate one) and 10.2 M4 .

When the error occurs the drivers in Windows Device Manager disappear (it doesn't even get shown in the hidden ones).

These are the windows logs where the error occurred.
Device USB\VID_17E9&PID_6000&MI_00\7&129a4456&0&0000 had a problem starting.

Driver Name: oem48.inf
Class Guid: {4d36e968-e325-11ce-bfc1-08002be10318}
Service: WUDFRd
Lower Filters:
Upper Filters: IndirectKmd
Problem: 0x0
Problem Status: 0xC00000E5


The Sabrent device works correctly on other devices (so also the drivers do on the newer version) but they do not on the Asus Laptop I stated.

Could you give me support?
Attached Images
File Type: jpg unnamed.jpg (18.7 KB, 0 views)
FrancescoBoxxo is offline   Reply With Quote
Reply

Tags
docking station, drivers, sabrent ws-wspd-eu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.