Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Windows Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-15-2022, 08:00 PM   #1
Step
Junior Member
 
Join Date: Nov 2022
Posts: 1
Exclamation WINDOWS10 PnP drivers Malfunction *EDIT: SOLVED

Hi,

My WAVLINK Displaylink Dock (UG69PD10) suddenly stopped working with the Plug and Play drivers that are included in Windows.
All other functions of the dock seem OK,
The Displaylink pnp drivers show "working properly" but there are not screens detected.

When I upgrade to the new Displaylink driver it starts working again.. (replacing file dlidusb3.dll is enough)

Now my issue is that my other (work) computer is managed by the company and they refuse to install drivers. I'm not the only one at the company with this issue.
Why did the usb-c dock suddenly stop working with PnP drivers?? and why are these drivers so old? 16/04/2020
Is there a process to get a new PnP version?

I'm mailing with WAVLINK but currently we're at 'rebooting the device' style of troubleshooting...

Thanks for your help / insight,

br
Steven


EDIT: There seems to be an issue with the latest firmware in the Diplaylink driver.
When I rollback to 10.1 M1 it seems to upload a firmware that fixes the issue.
All laptops are working again. Also those with no (only Plug and Play) driver installed.

Last edited by Step; 11-21-2022 at 03:34 PM. Reason: Sharing solution.
Step is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.