Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Mac Software

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-28-2024, 07:56 AM   #1
heramben
Junior Member
 
Join Date: Jan 2024
Posts: 1
Unhappy Unable to use ugreen for macbook pro

Just bought a Ugreem 90912 but i am unable to display it on my 2 screens. I have 2 view sonic screen. Already installed display link and followed all the instructions. Both my HDMI cables are good. I have a Macbook M1 running on macOS Sonma 14.3. What am i doing wrong? Can someone help plsss
heramben is offline   Reply With Quote
Old 03-06-2024, 02:30 PM   #2
finc23
Junior Member
 
Join Date: Mar 2024
Posts: 1
Default Having the same issue

yea I've just purchased the Ugreen docking station 90912 and connected it to my MacBook Air, but it is also not working. There is no device recognised when I connect it to my laptop.
finc23 is offline   Reply With Quote
Old 05-06-2024, 03:16 PM   #3
cdeneen
Junior Member
 
Join Date: May 2024
Posts: 4
Default

I'm using the same dock with a Macbook Pro M3. Connected with HDMI to two BenQ PD2700U monitors. Each monitor is also connected via USB to act a hub for my keyboard, mouse, webcam, etc

The dual monitor set up works as expected with Displaylink 1.10.1. The USB also works most of the time:

The few issues I've run into:

- Upon disconnecting or reconnecting the USB for one or both monitors has been lost a few times. I have to disconnect the USB and reconnect. I have the "Allow accessories to connect" to "always". This may be unrelated though because of recent changes to USB security (even though I changed it to always)

- The experimental resolution in Displaylink manager work but in reverse. I'm using 2560x1440 but it's not actually behaving as Displaylink states.

Displaylink states that your monitor must work with these resolutions meaning it outputs that direct resolution if you enable the option.

With the option on if I select 1440p OSX is scaling and the monitor receives a 2160p signal, this is how it normally works when directly connected as OSX scales lower resolutions.

With the option off if I select 1440p it outputs a 1440p signal. This forces the monitor to scale which is lower quality.




This isn't a problem but if you have a 4k and want bigger UI elements using this option on it works as you would expect without a dock. Very weird
cdeneen is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.