Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-17-2023, 02:59 AM   #1
Stealthrt
Junior Member
 
Join Date: Mar 2023
Posts: 1
Question Raspberry Pi Zero 2 W unable to rotate/orientate Vue monitor screen

Hello!

I am currently trying to set up my Mimo Vue 10.1" Capacitive Touch Display, USB (UM-1080C-G) with my Raspberry Pi Zero 2 W running the latest Raspbian OS (2023-02-21) Debian Bullseye 32-bit.



I have followed the instructions on the page https://www.mimomonitors.com/pages/u...raspberry-pi-3 and have my Vue running just fine in both the 1280x800 resolution and with the touch working as well.

The only problem I am encountering is that I am unable to rotate/Orientate the screen 90 degree.

I have tried the following:
Code:
david@rpi:~ $ xrandr -o left
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  2 (RRSetScreenConfig)
  Serial number of failed request:  14
  Current serial number in output stream:  14

david@rpi:~ $ xrandr --output default --rotation left
xrandr: output default cannot use rotation "left" reflection "none"

david@rpi:~ $ xrandr --output default --rotate left
xrandr: output default cannot use rotation "left" reflection "none"
I have also tried editing the /boot/config.txt using the following inside the:

Code:
# Enable DRM VC4 V3D driver
dtoverlay=vc4-kms-v3d
max_framebuffers=2
Added:
Code:
 lcd_rotate=1
And also added:
Code:
display_rotate=1
And I also tried them both
Code:
 lcd_rotate=1
  display_rotate=1
And commenting out
Code:
dtoverlay=vc4-kms-v3d
Having commented out dtoverlay=vc4-kms-v3d cause no image on the LCD.
Having un-commented out dtoverlay=vc4-kms-v3d and using lcd_rotate=1 resulted in the same normal horizontal view.
Having un-commented out dtoverlay=vc4-kms-v3d and commenting out lcd_rotate=1 while using display_rotate=1 resulted in the same normal horizontal view.

It would be great if you have a solution for this!

Thanks!

David

==================================
== Raspberry Pi & display stats below ==
==================================


Code:
david@rpi:~ $ xrandr --listmonitors
xrandr: Failed to get size of gamma for output default
Monitors: 1
 0: +*default 1280/339x800/212+0+0  default

david@rpi:~ $ xrandr --listactivemonitors
xrandr: Failed to get size of gamma for output default
Monitors: 1
 0: +*default 1280/339x800/212+0+0  default

david@rpi:~ $ xrandr --screen 0
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1280 x 800, current 1280 x 800, maximum 1280 x 800
default connected primary 1280x800+0+0 0mm x 0mm
   1280x800      60.00* 

david@rpi:~ $ cat /proc/cpuinfo
Hardware: BCM2835
Revision : 902120
Model : Raspberry Pi Zero 2 W Rev 1.0

david@rpi:~ $ cat /proc/version
Linux version 5.15.84-v7+ (dom@buildbot) (arm-linux-gnueabihf-gcc-8 (Ubuntu/Linaro 8.4.0-3ubuntu1) 8.4.0, GNU ld (GNU Binutils for Ubuntu) 2.34) #1613 SMP Thu Jan 5 11:59:48 GMT 2023

david@rpi:~ $ lsusb
Bus 001 Device 004: ID 413c:3012 Dell Computer Corp. Optical Wheel Mouse
Bus 001 Device 006: ID 266e:0102 Silicon Integrated Systems SiS HID Touch Controller
Bus 001 Device 005: ID 17e9:016b DisplayLink MIMO VUE HD
Bus 001 Device 003: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 002: ID 214b:7250 Huasheng Electronics USB2.0 HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

david@rpi:~ $ inxi -G
Graphics:  Device-1: bcm2835-hdmi driver: vc4_hdmi v: N/A 
           Device-2: bcm2835-vc4 driver: vc4_drm v: N/A 
           Device-3: DisplayLink MIMO VUE HD type: USB driver: udlfb 
           Display: x11 server: X.Org 1.20.11 driver: loaded: fbdev resolution: 1280x800~60Hz 
           OpenGL: renderer: llvmpipe (LLVM 11.0.1 128 bits) v: 4.5 Mesa 20.3.5 

david@rpi:~ $ fbset
mode "1280x800-60"
    # D: 71.093 MHz, H: 49.370 kHz, V: 59.988 Hz
    geometry 1280 800 1280 800 16
    timings 14066 110 20 15 3 30 5
    rgba 5/11,6/5,5/0,0/0
endmode

david@rpi:~ $ xrandr --verbose
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1280 x 800, current 1280 x 800, maximum 1280 x 800
default connected primary 1280x800+0+0 (0x410) normal (normal) 0mm x 0mm
	Identifier: 0x40f
	Timestamp:  18641
	Subpixel:   unknown
	Clones:    
	CRTC:       0
	CRTCs:      0
	Transform:  1.000000 0.000000 0.000000
	            0.000000 1.000000 0.000000
	            0.000000 0.000000 1.000000
	           filter: 
	non-desktop: 0 
		supported: 0, 1
  1280x800 (0x410) 61.440MHz *current
        h: width  1280 start    0 end    0 total 1280 skew    0 clock  48.00KHz
        v: height  800 start    0 end    0 total  800           clock  60.00Hz
Stealthrt is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.