Go Back   DisplayLink Forum > DisplayLink Graphics Technology > Linux and Open Source

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-19-2020, 08:35 AM   #1
highbeta
Junior Member
 
Join Date: Jul 2020
Posts: 1
Default Linux Mint 20 failed to install displaylink-driver-5.3.1.34

Hello,

I upgraded system to Linux Mint 20 and tried to install the latest displaylink-driver-5.3.1.34. Unfortunately the installation failed:

Code:
x@y:~/Downloads$ sudo ./displaylink-driver-5.3.1.34.run
Verifying archive integrity...  100%   All good.
Uncompressing DisplayLink Linux Driver 5.3.1.34  100%  
DisplayLink Linux Software 5.3.1.34 install script called: 
Distribution discovered: Linux Mint 20
logname: no login name
Failed to get session path: No session 'SESSION' known

Installing

[ Installing EVDI ]
[[ Installing EVDI DKMS module ]]
Error! DKMS tree already contains: evdi-1.7.0
You cannot add the same module/version combo more than once.
EVDI DKMS module already installed.
[[ Installing module configuration files ]]
[[ Installing EVDI library ]]
cc -I../module -std=gnu99 -fPIC    -c -o evdi_lib.o evdi_lib.c
In file included from evdi_lib.c:5:
/usr/lib/gcc/x86_64-linux-gnu/9/include/stdint.h:9:16: fatal error: stdint.h: No such file or directory
    9 | # include_next <stdint.h>
      |                ^~~~~~~~~~
compilation terminated.
make: *** [<builtin>: evdi_lib.o] Error 1
ERROR: Failed to build evdi/5.3.1.34 library.
Can somebody help?

Thanks in advance.
Highbeta

Last edited by highbeta; 07-19-2020 at 05:26 PM.
highbeta is offline   Reply With Quote
Old 07-29-2020, 10:33 PM   #2
JewbixCube
Junior Member
 
Join Date: Jul 2020
Posts: 1
Default

I was able to get past this issue on my Linux Mint 20 machine by installing the following:

Code:
sudo apt-get install libc6-dev
Then I re-ran the ./displaylink-driver-5.3.1.34.run script and it worked.
JewbixCube is offline   Reply With Quote
Old 08-03-2020, 06:17 PM   #3
Joris
Junior Member
 
Join Date: Aug 2020
Posts: 3
Default

Quote:
Originally Posted by JewbixCube View Post
I was able to get past this issue on my Linux Mint 20 machine by installing the following:

Code:
sudo apt-get install libc6-dev
Then I re-ran the ./displaylink-driver-5.3.1.34.run script and it worked.
Awesome, that worked. Thank you!
Joris is offline   Reply With Quote
Old 08-07-2020, 06:03 PM   #4
Wanbli
Junior Member
 
Join Date: Aug 2020
Posts: 1
Default

Quote:
Originally Posted by JewbixCube View Post
I was able to get past this issue on my Linux Mint 20 machine by installing the following:

Code:
sudo apt-get install libc6-dev
Then I re-ran the ./displaylink-driver-5.3.1.34.run script and it worked.
Can someone please help me. I'm NOT a linux user and I find this OS VERY FRUSTRATING!!!
I tried to double click on the Displaylink driver file, it ran and then stopped after about 15 minutes. I tried to run it in terminal, but I get "Command Not Found"
here's the terminal results:
sudo ./displaylink-driver-5.3.1.34.run
sudo: ./displaylink-driver-5.3.1.34.run: command not found
Why is everything in this OS so damned difficult? Does MS own double click and a software gets installed? Jeeez
Wanbli is offline   Reply With Quote
Old 08-09-2020, 08:59 PM   #5
Stuart Mantel
Junior Member
 
Join Date: Jul 2020
Posts: 1
Default

I have tried this solution and it did not work.

I completely installed displaylink.
I completely installed xserver
I rebooted
I updated libc6-dev and was told by the system the latest version was already iunstalled
I installed displaylink without any error.

My 2 external displays are not seen.

Lenovo Carbon X1
Thinkpad USB 3 dock
Linux Mint 20
This configuration worked before my latest Linux update

Anyone else have any suggestions?
Stuart Mantel is offline   Reply With Quote
Old 08-29-2020, 01:10 PM   #6
Gr3ghammett
Junior Member
 
Join Date: Aug 2020
Posts: 1
Cool Hope this helps

Quote:
Originally Posted by Wanbli View Post
Can someone please help me. I'm NOT a linux user and I find this OS VERY FRUSTRATING!!!
I tried to double click on the Displaylink driver file, it ran and then stopped after about 15 minutes. I tried to run it in terminal, but I get "Command Not Found"
here's the terminal results:
sudo ./displaylink-driver-5.3.1.34.run
sudo: ./displaylink-driver-5.3.1.34.run: command not found
Why is everything in this OS so damned difficult? Does MS own double click and a software gets installed? Jeeez
It sounds like your issue may be that you are not in the location to where the driver file is saved. I'm assuming you downloaded it and didn't move it. You will need to go to where your browser downloads files (usually it's /home/Downloads unless you changed it within the browser).

Note below when I give commands, I type them in " marks, but you shouldn't use them. I only use them to help separate where the command begins and ends here.

The terminal defaults to your home folder when you first open it up. My recommendation would be to use the command "ls" (stands for "list". it lists all the items in the folder that you are. This is the equivalent of doing "dir" in MS-DOS/Windows Command prompt).

Move to the Downloads folder by typing "cd Downloads" (you can also type "cd Dow" and hit TAB to have it auto complete (something I use often).

Do "ls" again to validate that the driver file is in the same folder you are in. If it's there try the run command again "sudo ./displaylink-driver-5.3.1.34.run" and it should work.

If you get the same error as above about evdi, the 2nd comment fixed my issue with the command "sudo apt-get install libc6-dev"

So in short:
1) "ls" to validate you're in the /home/ directory
2) "cd Desktop" to move to the /home/Desktop/ folder (where the .run file should be)
3) "ls" to validate the driver file is in there.
4) "sudo ./displaylink-driver-5.3.1.34.run"
5) if you get the evdi error, do "sudo apt-get install libc6-dev"

I have been using Linux Distros for over 13 years. It definitely is an adjustment, but Linux MInt is actually pretty good and the closest I've seen to Windows. It takes a bit to get used to the nuances but I still prefer it (especially since you dont stuck with apps you can't remove like I.E. or Microsoft Edge ). If you have any questions, DM me here and I'm more than happy to help you with whatever questions you may have!

Last edited by Gr3ghammett; 08-29-2020 at 01:14 PM.
Gr3ghammett is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.